HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   RapidSSL - ISPConfig - Apache2 wont start (http://www.howtoforge.com/forums/showthread.php?t=60666)

DKLeader 25th February 2013 00:47

RapidSSL - ISPConfig - Apache2 wont start
 
Hi,

Bought a new SSL and somewere down the line I did something wrong. Apache crashed and now fails to start.
I have searched and tried the different options but without any luck.

ISPConfig 3.0.4.6
Setup is multiserver
Server is running Debian Lenny

I have checked the vhost file for the domain that I was adding SSL for and no lines could be found related to SSL or 443.

One fault I may have done is that I already had one domain on that IP with SSL running and was working.

I wnated to have SSL with wildcard on another domain.
Hope someone can help me as all domains are offline right now.

Best Regards
Jakob.

Parsec 25th February 2013 01:21

/var/log/apache2/error.log will tell you the reason why. "apache2ctl configtest" will also tell you.

DKLeader 25th February 2013 08:54

I have checked the /var/var/apache2/error.log and nothing in this one is posted when I try to restart apache.

Code:

web:~# /etc/init.d/apache2 start
Starting web server: apache2[Mon Feb 25 08:46:03 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
 failed!

And if I do apache2ctl configtest :
Code:

web:~# apache2ctl configtest
[Mon Feb 25 08:50:01 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
Syntax OK
web:~#

The error with NameVirtualHost has been there since I installed the server and it has been working fine until lat night when I added the SSL to one of the domains.

DKLeader 25th February 2013 19:31

Solved the part with apache not starting.
Didn't think that the domain with ssl that was working could be a problem. After I removed these apache could start.

But now my problem is that the vhost file doesn't get the SSL part added again. I have tried "Delete certificate" and remove the tick mark from SSL inside ISPConfig panel. Added the SSL tick mark again and "Create certificate" but when I check the vhost SSL part is not added.

I have checked on ther server and cert files are created in the ssl folder for the domain.


All times are GMT +2. The time now is 22:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.