HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   PHP not running, only downloading php file (http://www.howtoforge.com/forums/showthread.php?t=60662)

DiMoNd 24th February 2013 10:58

PHP not running, only downloading php file
 
Hi guys!


I have recently installed ubuntu server 12.10 following the HowtoForge guide with ispconfig 3. everything seems to be ok except the php..

Apache2 is running ok and html fine. But when I try to visit a *.php page it does not show the pages but downloads the files instead.

I have been trying to fix this issue by following some solutions here and on other sites but nothing happens..

Any help appreciated!


Thanks in advance!

ressel 24th February 2013 13:36

Quote:

Originally Posted by DiMoNd (Post 292488)
Hi guys!


I have recently installed ubuntu server 12.10 following the HowtoForge guide with ispconfig 3. everything seems to be ok except the php..

Apache2 is running ok and html fine. But when I try to visit a *.php page it does not show the pages but downloads the files instead.

I have been trying to fix this issue by following some solutions here and on other sites but nothing happens..

Any help appreciated!


Thanks in advance!

Try to run following command:
Code:

apt-get install libapache2-mod-php5

Stubbsy92 25th February 2013 11:49

Perhaps try "a2enmod php5"

DiMoNd 26th February 2013 08:22

Hey guys!

Thanks for replying..

ressel, I tried the command you wrote but it didn't fix the problem, so I followed the guide to install Debian Sqeeze with ispconfig 3 and everything seems to work fine.


All times are GMT +2. The time now is 10:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.