HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Database backup ISPConfig 3.0.5 RC2 (http://www.howtoforge.com/forums/showthread.php?t=60646)

Gijs 22nd February 2013 15:56

Database backup ISPConfig 3.0.5 RC2
 
Hi,

I installed ISPConfig 3.0.5 RC2 and it says that the backup should include the database which is beautifull but if I choose "download" in the backup section, the backup included in the /backup doesn't contain the database file which is less beautifull I think.

Am I doing something wrong or is the database only included in the restore process?

Thanks for the answer.

pawan 22nd February 2013 22:43

You should assign database to your website to have the database backup, if yours is a old installation, you have to do it manually for every website.

For newer website the ispconfig will automatically ask you to assign the database.

Gijs 23rd February 2013 14:03

Thats it! Thanks for the help

Gijs 26th February 2013 12:56

Hi Pawan,

I thought that was the solution but it isn't. The database is still not backuped. If I download the backup file it contains only the FTP data. The database is not included in there.

Do you have any other suggestions?

Thanks again

till 26th February 2013 13:56

Backups are created nightly. Have you waited until the next day before you tried the download again?

Gijs 26th February 2013 14:17

Well, their are also backups made this night and they don't include the databases either. And it is a fresh website created on the 3.0.5 final.

Their don't have to be any specific settings right? Just create a database user, the database and the website isn't it?

till 26th February 2013 14:20

Quote:

Their don't have to be any specific settings right? Just create a database user, the database and the website isn't it?
Yes. Please check that the applications sudo and mysqldump are installed on your server and that the mysql root password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is correct and does not contain any special chars.

Gijs 26th February 2013 14:31

Aha, mysql_clientdb.conf says that the mysql database is localhost, but it is not, so that should be the solution.
I will have to wait for the next backup tonight but thanks so far again!

Gijs 4th March 2013 14:43

It's working now!
External MySQL backup still didn't work but I didn't see any good reason to use an external database so I am using the local MySQL database now and that works with the backup.

arraken 17th January 2014 14:22

Hi,

In my multiserver setup, the db backup also doesn't work. The webserver is on a different server than the db server. I have updated my mysql_clientdb.conf file accordingly:

Code:

<?php

$clientdb_host                  = 'db1.domain.tld';
$clientdb_user                  = 'root';
$clientdb_password              = 'rootpassword for mysql on db1';

?>

Mysqldump and sudo is installed on both servers.

However, if I do:
Code:

mysqldump -h db1.domain.tld -u root -p c1testdb1 > c1testdb.dump
I get:
Code:

Access denied for user 'root'@'web1.domai.tld' (using password: YES) when trying to connect
Does that indicate the problem?


All times are GMT +2. The time now is 19:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.