HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Errors in Falko's Virtual User Mail Setup Tutorial (http://www.howtoforge.com/forums/showthread.php?t=60645)

Noah 22nd February 2013 01:43

Errors in Falko's Virtual User Mail Setup Tutorial
 
My old VPS died (KiloServe), they just disappeared overnight and have been gone for 3 days. Weird. Anyway, I'm on Ubuntu 12.04 now and still having problems with this tutorial. First:

Code:

root@server1:/tmp/dcc-dccproc-1.3.144# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address          Foreign Address        State      PID/Program name
tcp        0      0 localhost:smtp          *:*                    LISTEN      559/sendmail: MTA:
tcp        0      0 localhost:10024        *:*                    LISTEN      24435/amavisd (mast
tcp        0      0 localhost:mysql        *:*                    LISTEN      6011/mysqld   
tcp        0      0 localhost:submission    *:*                    LISTEN      559/sendmail: MTA:
tcp        0      0 *:ssh                  *:*                    LISTEN      338/sshd       
tcp        0    48 server1.storbo.net:ssh  S0106b88d1259b6c3:43235 ESTABLISHED 19395/0       
tcp6      0      0 [::]:imaps              [::]:*                  LISTEN      19794/couriertcpd
tcp6      0      0 [::]:pop3s              [::]:*                  LISTEN      19826/couriertcpd
tcp6      0      0 [::]:pop3              [::]:*                  LISTEN      19807/couriertcpd
tcp6      0      0 [::]:imap2              [::]:*                  LISTEN      19770/couriertcpd
tcp6      0      0 [::]:http              [::]:*                  LISTEN      6475/apache2   
tcp6      0      0 [::]:ssh                [::]:*                  LISTEN      338/sshd

I should be seeing "master" in there listening on port 25, but I am not. Second:

Code:

root@server1:/tmp/dcc-dccproc-1.3.144# spamassassin --lint
Feb 22 04:40:14.385 [31068] warn: config: SpamAssassin failed to parse line, "/usr/bin/pyzor" is not valid for "pyzor_path", skipping: pyzor_path /usr/bin/pyzor
Feb 22 04:40:14.978 [31068] warn: lint: 1 issues detected, please rerun with debug enabled for more information

Should I keep going forward or what?

falko 22nd February 2013 13:56

Are you sure you followed the tutorial to the letter? I know it's working exactly as written.

Noah 22nd February 2013 14:24

I fixed the first problem by rebooting the box, then master showed up for smtp.

Would you be interested a part 2 to this tutorial that shows how to replace Squirrel mail with Roundcube?

Squirrel mail just shows a blank screen after login for me but I am too tired to go into details. My VPS provider vanished 3 days ago and I spend all day rebuilding.

Oh, and by the way, you rock for all the work you do, thanks.

falko 23rd February 2013 11:42

Quote:

Originally Posted by Noah (Post 292431)
Squirrel mail just shows a blank screen after login for me

You probably introduced a PHP syntax error when you edited the config.php of the change_sqlpass plugin.


All times are GMT +2. The time now is 22:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.