HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Relayhost no longer disables (http://www.howtoforge.com/forums/showthread.php?t=60571)

aldo 14th February 2013 19:05

Relayhost no longer disables
 
After enabling relayhost for a test (System, Server Config, Mail) even if I disable it (leaving relayhost, relayhost User, Password relayhost empty) it seems that the relayng continue.

Even reboot solved.

How do I disable relay?

Thanks.

till 14th February 2013 19:17

remove it from main.cf and then restart postfix.

aldo 14th February 2013 19:37

Thank you.

main.cf was already clean.

Restarted postfix but seems unresolved

The queue is not empty.

aldo 14th February 2013 19:47

Mmmm! One moment!

The problem only happens to the same domain.

Let me explain.

The servers that has problems is called xyz.domain1.tld and the problem occurs only if the recipient is @domain1.tld all recipients with different domain have no problems.

till 15th February 2013 09:22

Most likely you have somwere domain1.tld in /etc/postfix/main.cf or /etc/mailname. Change all occurrences from domain1.tld to xyz.domain1.tld.

aldo 15th February 2013 12:41

Thank you Till.

/etc/postfix/main.cf and /etc/mailname was clean (no occurrences of domain1.tld).

I found
mail.domain1.tld smtp_user:smtp_password
in /etc/postfix/sasl_passwd
that was exactly what set for hostrelay.

Should I remove it?

aldo 15th February 2013 14:53

I tried to empty /etc/postfix/sasl_passwd and seems to solve the problem.

aldo 18th November 2013 14:34

In a new similar case I also had to:

Code:

cd /etc/postfix
postmap hash:/etc/postfix/sasl_passwd
service postfix restart

this because despite having emptied the ISPConfig3 configuration related fields and the file /etc/postfix/sasl_passwd, postfix continued to relay undaunted.

Maybe something does not reset as it should in my installations.


All times are GMT +2. The time now is 01:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.