HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   amavis problems (http://www.howtoforge.com/forums/showthread.php?t=60488)

tahunasky 8th February 2013 14:53

amavis problems
 
Hi, I have had a problem today where one of my servers had amavis take up 40% + of cpu, with email stuck in the postfix que, and cron jobs not running.

This is what is in the syslog - the same 2 exact line outputs over and over..

Quote:

Feb 9 01:56:21 moa amavis[18265]: (!!)TROUBLE in child_init_hook: BDB no dbS: unable to allocate memory for mutex; resize mutex region, . at (eval 94) line 30.
Feb 9 01:56:21 moa amavis[18265]: (!)_DIE: Suicide in child_init_hook: BDB no dbS: unable to allocate memory for mutex; resize mutex region, . at (eval 94) line 30.
I stopped amavis and restarted and flushed the postfix que and everything seems to be working ok again. There was plenty of free RAM (350MB free) and disk space (200GB free) when this was happening.

Has anyone seen this before or know what has caused it as i cant find anything when i google it.

Server is running ubuntu 12.10 /postfix/dovecot/apache as per standard ISPconfig perfect server setup.

falko 9th February 2013 15:49

350MB of RAM is not that much - it can quickly be filled up. You should get more RAM.

tahunasky 9th February 2013 23:50

I think there is plently of ram, as very little virtual memory is being used - and at this very moment there is 450MB free.

On some of my older servers (HP e-pcs 40) which only have 512mb of total RAM and are running RHEL 6.1 with apache/postfix/dovecot/dnsmasq dont use any virtual memory, and have worked fine for years with between 100 and 125mb being used. So ram isnt the problem.


All times are GMT +2. The time now is 10:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.