HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Amavis: Open relay? Nonlocal recips but not originating (http://www.howtoforge.com/forums/showthread.php?t=60484)

Sir Henry 8th February 2013 08:42

Amavis: Open relay? Nonlocal recips but not originating
 
I know this warning has been added to Amavis to flag mails from non-local senders to non-local recipients. I have been trying to get rid of the warning in case the sender is SASL authenticated.

One recommendation I found was this:
Code:

$interface_policy{'10024'} = 'SASL_AUTH';
$policy_bank{'SASL_AUTH'} = {
  originating => 1,
};

But this goes way too far as ALL mails are routed from postfix to Amavis via port 10024. Using the submission port for authenticated senders is fine but I can't force all my people to do it.

Does anybody have a good solution for this? Maybe a second Amavis port for authenticated senders? Any better idea?


All times are GMT +2. The time now is 01:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.