HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Smtp greeting not received only from gmail (http://www.howtoforge.com/forums/showthread.php?t=60475)

jonk 7th February 2013 18:05

Smtp greeting not received only from gmail
 
I have postfix running on Ubuntu 12.04 and mails are sent without issues but from past few days have issues only while sending mail to gmail mail servers

Code:

telnet gmail-smtp-in.l.google.com 25
Trying 74.125.141.26..
Connected to gmail-smtp-in.l.google.com.
Escape character is '^]'.

It just hangs there and connection closed by foreign host.

But do not have any issues sending to yahoo, hotmail etc

IP address is not listed in any of the blacklists.

Pls help.

fr0stsp1re 8th February 2013 00:44

Not all SMTP servers will respond with a banner after you telnet into them. It is waiting for you to issue a command and the server is timing out waiting for it. At least that is what it seems like. Issue a HELO or EHLO command and see what happens.

jonk 8th February 2013 06:11

Tried it. No luck.

fr0stsp1re 9th February 2013 08:21

Did you try 465 as well? Try some of the other ports. Is it possible your ISP is filtering port 25?

I just tried telnet on that host you posted and it works fine for me.


Last login: Fri Feb 8 11:31:10 on console
Frosts-Mac-Pro:~ fr0stspire$ telnet
telnet> open
(to) gmail-smtp-in.l.google.com 25
Trying 173.194.79.27...
Connected to gmail-smtp-in.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP f9si43998037paw.256 - gsmtp
EHLO atomiccomputerservice@gmail.com
250-mx.google.com at your service, [50.76.107.157]
250-SIZE 35882577
250-8BITMIME
250-STARTTLS
250 ENHANCEDSTATUSCODES

If you have a firewall switch it off just for testing purposes. Try using telnet from a different host on your network. Seems like the issue is confined to your end. If you are on a DHCP assigned IP for your internet router, see if you can pick up a new ip by going to your mac address clone in your router, pick "use this mac address option" take any two or more numbers or letters and change them. hit save. Power cycle your router and you shall now have a new IP. Test again.

FYI if you are on a DHCP assigned IP on the host you are testing from, you will automatically be blacklisted since DHCP assigned blocks are almost always on blacklists by default. And you cannot be removed from a blacklisted IP block as your ISP is the one who put it there to begin with in most cases. They are trying to stop spam from all angles these days.


All times are GMT +2. The time now is 20:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.