HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig not listening (http://www.howtoforge.com/forums/showthread.php?t=60409)

sparktino 2nd February 2013 06:04

ISPConfig not listening
 
Hello after running the install script ISPConfig is not listening on port 8080.
The script ran successfully eventhough I noticed mysql start and stop was missing from the steps.
=============================
Configuring Jailkit
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring BIND
Configuring nginx
Configuring Vlogger
Configuring Apps vhost
Configuring Bastille Firewall

Installing ISPConfig
ISPConfig Port [8080]:

Configuring DBServer
Installing ISPConfig crontab
Restarting services ...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [ OK ]
Starting saslauthd: [ OK ]
Stopping Dovecot Imap: [ OK ]
If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
This message goes away after the first successful login.
Starting Dovecot Imap: [ OK ]
Reload service php-fpm done
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful
Reloading nginx: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Installation completed.
===========================================

Can anybody please tell what is wrong here.

Thanks

sparktino 2nd February 2013 13:55

Somebody please help me to find a solution :(

I really stuck at this point. Not sure what to do

Your help will be really appreciated

till 4th February 2013 12:09

Quote:

The script ran successfully eventhough I noticed mysql start and stop was missing from the steps.
Thats not missing. Mysql dos not have to be restarted.

Quote:

Can anybody please tell what is wrong here.
Please post the output of:

netstat -tap

and

iptables-L

sparktino 4th February 2013 15:50

Thank you Till for responding to this thread.

I reinstalled it after disabling the firewall. But the same result. So currently there are no firewall rules present in the server.
========

# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

========

Here is the output of netstat command. ISPconfig is not listening on port 8080

=======
# netstat -tlpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 127.0.0.1:199 0.0.0.0:* LISTEN 2059/snmpd
tcp 0 0 127.0.0.1:9000 0.0.0.0:* LISTEN 4875/php-fpm
tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 4834/master
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 4059/mysqld
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 0.0.0.0:9102 0.0.0.0:* LISTEN 2715/bacula-fd
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1900/portmap
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4982/nginx
tcp 0 0 10.8.72.1:53 0.0.0.0:* LISTEN 4961/named
tcp 0 0 xxx.xxx.xx.xxx:53 0.0.0.0:* LISTEN 4961/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 4961/named
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 4909/pure-ftpd (SER
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2122/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 2130/cupsd
tcp 0 0 127.0.0.1:63000 0.0.0.0:* LISTEN 1743/vmad-bin
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 4961/named
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 4834/master
tcp 0 0 :::993 :::* LISTEN 4863/dovecot
tcp 0 0 :::995 :::* LISTEN 4863/dovecot
tcp 0 0 :::110 :::* LISTEN 4863/dovecot
tcp 0 0 :::143 :::* LISTEN 4863/dovecot
tcp 0 0 :::53 :::* LISTEN 4961/named
tcp 0 0 :::21 :::* LISTEN 4909/pure-ftpd (SER
tcp 0 0 :::22 :::* LISTEN 2122/sshd
tcp 0 0 ::1:953 :::* LISTEN 4961/named
===========

sparktino 4th February 2013 19:56

I tried the installation in a fresh server. After installing all the necessarry services I executed the installation script. This time it showed mysql start/stop in the output. But ISPconfig did not get started.

=========
Configuring DBServer
Installing ISPConfig crontab
no crontab for root
no crontab for getmail
Restarting services ...
Stopping mysqld: [ OK ]
Starting mysqld: [ OK ]
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [FAILED]
Starting saslauthd: [ OK ]
Shutting down Mail Virus Scanner (amavisd): [FAILED]
Starting Mail Virus Scanner (amavisd): [ OK ]
Stopping Clam AntiVirus Daemon: [ OK ]
Starting Clam AntiVirus Daemon: [ OK ]
Stopping Dovecot Imap: [ OK ]
If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
This message goes away after the first successful login.
Starting Dovecot Imap: [ OK ]
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful
Reloading nginx: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Installation completed.
=======

Is there any thing wrong with the installation script?.
I am running this on a Centos 5.5 64-bit machine.

falko 5th February 2013 20:07

Have you tried to restart Apache?

Code:

/etc/init.d/httpd restart

sparktino 5th February 2013 20:25

Falko,

As you can see from the installation output posted in my previous reply I am using nginx instead of apache.

Thanks

falko 6th February 2013 13:24

Which distribution do you use? What's your nginx version? Have you tried to restart nginx?

sparktino 6th February 2013 14:24

Falko,

I am using Centos 5.5 64-bit. I tried to install ispconfig in two servers. In one server I used nginx version nginx/1.0.3 and in other nginx/1.2.1.

Yes, I restarted nginx many times and that did not make any difference.
Is there any startup script for ispconfig that gets installed during the installation? . I can't see one in /etc/init.d/

Thanks

falko 9th February 2013 08:53

How did you install nginx? I think the nginx version coming with CentOS 5.5 is much older then what you use, so I guess you installed nginx manually somehow.

Quote:

Is there any startup script for ispconfig that gets installed during the installation? . I can't see one in /etc/init.d/
No, ISPConfig 3 has no startup script.


All times are GMT +2. The time now is 18:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.