HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Postfix - 500 Syntax Error (http://www.howtoforge.com/forums/showthread.php?t=60404)

chrisg 1st February 2013 19:25

Postfix - 500 Syntax Error
 
I have set up a postfix server in front of Exchange.

Things seem to have been running fine then lately I got a report from two different domains that are rejecting emails from us.

This is the message from the bounced emails: host mini.tetherinc.com[67.1xx.1xx.xx] said: 500 Syntax
error, command unrecognized (in reply to DATA command)

So I ssh'd into my postfix server and tried a manual telnet e-mail. This is what happens:

root@antispam:~# telnet 67.1xx.1xx.xx 25
Trying 67.1xx.1xx.xx...
Connected to 67.1xx.1xx.xx.
Escape character is '^]'.
220 mini.tetherinc.com ESMTP Service ready
HELO antispam.appart.com
250 Requested mail action okay, completed
mail from: emailaddress@domain.com
250 Requested mail action okay, completed
rcpt to: emailaddress2@domain.com
250 Requested mail action okay, completed
data
500 Syntax error, command unrecognized


Any ideas on what could possibly be causing this? It is only two domains that have shown this error but they are very important domains that we need to be able to e-mail with no problems. Please help!!:confused:

falko 2nd February 2013 12:07

Are there any errors in your mail log (in the /var/log/ directory)?

chrisg 4th February 2013 18:39

There are no errors in the log file when I attempt to send to that domain. It reads as if the e-mail goes thru, then gets rejected and an NDR gets sent back containing the error 500 Syntax error, command unrecognized (in reply to DATA command)

falko 5th February 2013 20:09

Maybe those external servers blacklisted your mail server. It is possible that they were configured to reply with a (misleading) 500 error.

chrisg 5th February 2013 20:24

I have solved the issue for one of the domains. It was un-related. After getting more information from the user I found out she was using an accounting program to send the emails therefore relaying which the other server denied.

I still am having an issue with the server giving me the syntax error.

This is a client who emailed us asking for a quote and then we couldn't respond so I don't think we were blacklisted as it was not a domain we were emailing previously. Also, our domain doesn't appear on any of the blacklists on the internet when doing a quick search.


All times are GMT +2. The time now is 16:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.