HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Configuring DNS for Primary Servers In Multi-Server Setup (http://www.howtoforge.com/forums/showthread.php?t=60339)

darinpeterson 26th January 2013 22:05

Configuring DNS for Primary Servers In Multi-Server Setup
 
Hi,

I have read many of the howto documents regarding multi-server and DNS server setup, but none of them are clear on configuring DNS records for these primary servers.

The DNS servers are working fine and I have setup the DNS records at my hosting provider. I have created websites on my multi-server setup and they are working fine.

Here is where I have trouble, say I have the following primary servers setup in my configuration:

web.server.com - 1.2.3.4
db.server.com - 1.2.3.5
mail.server.com - 1.2.3.6
git.server.com - 1.2.3.6
ns1.server.com - 1.2.3.7
ns2.server.com - 1.2.3.8

In ISP Config 3, what DNS records are needed to do the following:

(1) Create records to access web.server.com via https://www.server.com:8080 instead of https://1.2.3.4:8080

(2) Create records that will make use of db.server.com as well as 1.2.3.5.

(3) Create records that will allow me and my clients to access my mail server like this https://mail.server.com. I don't even think the server is setup properly to access webmail via https://1.2.3.6, but that information was not provided in the howto documentation.

(4) Create records that will allow me to access my git server via git.server.com instead of 1.2.3.6.

These are the howto documents that I referred to during the multi-server setup, and I am unable to complete the setup with the information provided:

http://www.howtoforge.com/virtual-mu...th-ispconfig-3

http://www.howtoforge.com/multiserve...th-ispconfig-3

http://www.howtoforge.com/how-to-run...debian-squeeze

Is there someone who can help me complete this setup?

Thanks in advance...

Darin

pititis 27th January 2013 01:02

In ispconfig:

Step 1 - Add a zone for server.com
Step 2 - Click on the new zone and add an A record for each host.

Example for the host web.server.com (A record dialog):

Hostname: web
Ip Address: 1.2.3.4
TTL: 86400


Ready!

darinpeterson 27th January 2013 01:54

Server Now Working! Nice!
 
Thank you pititis...

That worked perfectly. I entered A records for mail, db, web, git, and also ns1, and ns2.

Maybe the problem was that I did not add A records for ns1 and ns2? I thought that was taken care of on the side of my host?

After entering the A records, I entered a CNAME record for www to web. Now I can do https://www.server.com:8080...

ONE MORE QUESTION:
When creating a new website and new DNS records, how do I correctly point the user's site to mail.server.com?

Example: I create a domain for client.com. What will the DNS records look like for their email?

pititis 27th January 2013 02:26

Quote:

Originally Posted by darinpeterson (Post 291189)

Maybe the problem was that I did not add A records for ns1 and ns2?

Yes.

Quote:

Originally Posted by darinpeterson (Post 291189)

ONE MORE QUESTION:
When creating a new website and new DNS records, how do I correctly point the user's site to mail.server.com?

Example: I create a domain for client.com. What will the DNS records look like for their email?

Easy because mail.server.com is already defined. You must only add a MX record pointing to mail.server.com for the domain client.com

Example for the domain client.com (MX dialog):

Hostname: client.com.
Mailserver hostname: mail.server.com.
Priority: 10
TTL: 86400

(please note the dots)

However I like to use mail.client.com, it's easy for the customers. It's easy to remember and easy when configure the email software. If you want to use this, add an A record for mail pointing to the mail server ip and a MX record pointing to mail.client.com.

Cheers!

darinpeterson 27th January 2013 04:14

Something is not quite right.
 
Thanks again for taking the time to reply to my question. This time, the solution didn't work. Now, I don't know whether that's due to improper configuration or that there is an issue with the mail server. ISP Config 3, says all green and that everything is good with the mail server.

Here is my configuration for client.com:

A Record for website:
client.com.
1.2.3.4

A Record for mail:
mail
1.2.3.6

A record for www:
www
1.2.3.4

MX record for mail:
client.com.
mail.client.com.

NS record:
client.com.
ns1.server.com.

NS record:
client.com.
ns2.server.com.

Do you recognize any issues with the configuration? Recommendations?

pititis 27th January 2013 12:48

What is in your mail.log?

darinpeterson 27th January 2013 15:54

mail.log
 
This is my mail log, and it appears that it's refusing the connection?

Jan 27 03:32:52 mail postfix/pickup[13432]: 210D5363C40E: uid=0 from=<root>
Jan 27 03:32:52 mail postfix/cleanup[13439]: 210D5363C40E: message-id=<20130127033252.210D5363C40E@mail.server.com>
Jan 27 03:32:52 mail postfix/qmgr[1161]: 210D5363C40E: from=<root@mail.server.com>, size=1151, nrcpt=1 (queue active)
Jan 27 03:32:52 mail postfix/smtp[13452]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Jan 27 03:32:52 mail postfix/smtp[13452]: 210D5363C40E: to=<root@mail.server.com>, orig_to=<root>, relay=none, delay=0.04, delays=0.03/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Jan 27 03:35:01 mail dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Jan 27 03:35:01 mail dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Jan 27 03:35:01 mail postfix/smtpd[13514]: connect from localhost[127.0.0.1]
Jan 27 03:35:01 mail postfix/smtpd[13514]: lost connection after CONNECT from localhost[127.0.0.1]
Jan 27 03:35:01 mail postfix/smtpd[13514]: disconnect from localhost[127.0.0.1]
Jan 27 03:39:06 mail postfix/qmgr[1161]: 210D5363C40E: from=<root@mail.server.com>, size=1151, nrcpt=1 (queue active)
Jan 27 03:39:06 mail postfix/smtp[13624]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

ISSUE RESOLVED.
I found my mistake... I checked the "Disable POP3 checkbox" after mistaking it for being an enable control option. I guess I can blame it on being tired after a full day of server configuration work, and not taking the time to read carefully. :)

Thank you for your help!

pititis 27th January 2013 20:01

:) Glad to help you


All times are GMT +2. The time now is 13:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.