HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Postfix UPGRADED: Virtual Users And Domains With Postfix, Courier, MySQL And Squirrel (http://www.howtoforge.com/forums/showthread.php?t=60274)

stealthy 20th January 2013 13:56

Postfix UPGRADED: Virtual Users And Domains With Postfix, Courier, MySQL And Squirrel
 
I have followed Falko's tutorial http://www.howtoforge.com/virtual-us...l-ubuntu-12.10 .

The interestting part was to have user quotas.

Then, without a though I ran apt-get upgrade and this upgraded my patched Postfix. Ooops.

Now, every time I restart Postfix, I get these warnings that "....warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes....."

I am afraid I messed up the quota patch. Any suggestions?

suntribe 21st January 2013 09:36

I had the same scenario and at the end, I decided to go without the quota... I simply removed those unrecognized parameters from main.cf Postfix config file and now everything is working...

stealthy 21st January 2013 11:55

Quote:

Originally Posted by suntribe (Post 290949)
I had the same scenario and at the end, I decided to go without the quota... I simply removed those unrecognized parameters from main.cf Postfix config file and now everything is working...

Same here. The setup still works. I guess I could go back, recompile the old version....... DON'T FIX IT IF AIN'T BROKE!

stealthy 27th January 2013 01:23

Does this setup really work? That's a good question.

I see a header in the received emails that says X-Virus-Scanned: Debian amavisd-new at stupid.domain.com

I don't see any headers with reference to SPAM, spam score, SpamAssassin. So I am NOT convinced that SA is running properly.

More so because yesterday I received a spam message that shouldn't have gotten through at all.

Would anyone here have a suggestion how to add the SpamAssassin headers into the messages and make sure that SA works?

Thanks!

stealthy 27th January 2013 02:42

If you want to force the X-SPAM headers, you need to edit /etc/amavis/conf.d/50-user
by adding this line:
Code:

@local_domains_acl = ( "." );
And this is how it looks in the email message headers:
Code:

X-Virus-Scanned: Debian amavisd-new at my.awesome.tld
X-Spam-Flag: NO
X-Spam-Score: -1.1
X-Spam-Level:
X-Spam-Status: No, score=-1.1 tagged_above=-9999 required=6.31
        tests=[ALL_TRUSTED=-1, DKIM_SIGNED=0.1, DKIM_VALID=-0.1,
        DKIM_VALID_AU=-0.1] autolearn=ham


stealthy 27th January 2013 02:51

Here is excerpt from my mail.info log, a message I tried sending to myself with some common spam words (like pharma):

Code:

Jan 27 09:42:58 myhostname amavis[6658]: (06658-01) Blocked SPAM {DiscardedInbound,Quarantined}, [198.143.169.10]:58187 [198.143.169.10] <csyztdc+nnk0hw@guerrillamail.com> -> <name@myhostname.tld>, quarantine: z/spam-zRf-0a_2SC1x.gz, Queue-ID: 4FF02276FB, Message-ID: <7917653c03af8d127e23bd6fe9edae0aed22@guerrillamail.com>, mail_id: zRf-0a_2SC1x, Hits: 6.393, size: 1617, dkim_sd=better:guerrillamail.com, 1938 ms
Jan 27 09:42:58 myhostname postfix/smtp[6705]: 4FF02276FB: to=<name@myhostname.tld>, relay=127.0.0.1[127.0.0.1]:10024, delay=4.3, delays=2.3/0.07/0.02/1.9, dsn=2.7.0, status=sent (250 2.7.0 Ok, discarded, id=06658-01 - spam)

Thumbs up!

I still need to learn more about using SpamAssassin.


All times are GMT +2. The time now is 14:52.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.