HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Apache failure to start due to SSL (http://www.howtoforge.com/forums/showthread.php?t=60252)

thedoc351 18th January 2013 02:21

Apache failure to start due to SSL
 
I have a site that demands a SSL cert. The cert expired so I used your guide to generate a new certificate then followed the guide to use RapidSSL. Now when I try to start apache I get domain.bundle does not exist or is empty. So after getting that I copied the new certs into a file called domain.bundle and tried again to start apache. Now I see this: Restarting web server: apache2 failed! Anyone's help is appreciated. I really need to get this site up and running again ASAP.

thedoc351 18th January 2013 03:48

more information
 
I would like to add that this is ispconfig 3.4. The original certificate was a free one from comodo that was used. I did delete the certificate in ispconfig ssl directive and that is when this problem started.

falko 18th January 2013 11:26

Did you replace Comodo's bundle certificate with the one from RapidSSL?

thedoc351 18th January 2013 11:59

Yes I followed your tutorial to the letter. Could you tell me how I might generate new self signed so that apache will start and I can start over?

okay here is what I have done so far. I disabled ssl and apache started. If I enable ssl apache fails to start. I assume this is from an invalid cert. What is the procedure to create new certs and enable ssl once more? This is a debian Lenny install of ispconfig 3.4

falko 21st January 2013 19:24

Delete the cert in ISPConfig and create a new one.


All times are GMT +2. The time now is 14:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.