HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Delay in domain name recognition (http://www.howtoforge.com/forums/showthread.php?t=60244)

mmckenna 17th January 2013 15:15

Delay in domain name recognition
 
Hi all,

I'm just wondering if there is a way to reduce the time between creating a site in an ISPConfig server and for it to be recognised as a valid address on a client machine. I am using a local host server which is running nginx. At present I have to restart bind on my server and flush my DNS on a client machine in order to get the site recognised.

Thanks in advance,
M.

till 17th January 2013 15:34

The bind restart is not required as bind is restarted / reloaded automatically when the domain gets created in dns. The issue is caused by the dns cache on your client machine or by a caching dns server which is used by your client computer to resolve names. A dns record has a field "ttl" which sets the time that caching servers hold a domain name in its cache vbefore they query your master dns server again. So if you set ttl to a smaller number, the changes will get recognized faster.

mmckenna 17th January 2013 15:43

Thanks Till, I'll have a look at reducing the ttl, makes sense.


All times are GMT +2. The time now is 16:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.