HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Turnkey & ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=60231)

SamTzu 16th January 2013 10:40

Turnkey & ISPConfig
 
I installed ISPConfig on a Turnkey OpenVZ template and got it work but for some reason the System State show Web-Server as Offline.

Where can I set that so that it will show correct system state for Apache?

till 16th January 2013 10:44

Ensure that apache listens on localhost as well.

SamTzu 16th January 2013 12:37

The only difference I see in the /etc/apache2/ports.conf is that ISPConfig normally has these...

Quote:

NameVirtualHost *:80
Listen 80
And the Turnkey has only
Quote:

Listen 80

till 16th January 2013 15:59

Are you able to accessapaxhe at localhost e.g. with:

telnet localhost 80

SamTzu 17th January 2013 07:30

Yes. I can telnet to localhost on port 80 (and to 127.0.0.1).

till 17th January 2013 10:24

Thats what ispconfig is doing to check if the server is online. Maybe turnkey linux has disabled any php options then or a similar problem.

rogershado 18th January 2013 10:02

Quote:

Originally Posted by SamTzu (Post 290792)
The only difference I see in the /etc/apache2/ports.conf is that ISPConfig normally has these...



And the Turnkey has only

which Turnkey are you using because in mine after install off ispconfig it look like this

Quote:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>
have 5 running
And all work perfect

both on stable and 3.0.5 rc


All times are GMT +2. The time now is 04:06.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.