HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   weird behavior with perfect Debian nginx server + ISPCFG3 (http://www.howtoforge.com/forums/showthread.php?t=60191)

Ovidiu 11th January 2013 12:16

weird behavior with perfect Debian nginx server + ISPCFG3
 
I followed this tutorial: http://www.howtoforge.com/perfect-se...nx-ispconfig-3

Code:

/var/www/clients/client2# ls -al
total 12
drwxr-xr-x 3 root root    4096 Jan  6 16:04 .
drwxr-xr-x 3 root root    4096 Jan  6 16:04 ..
lrwxrwxrwx 1 root root      30 Jan  6 16:04 pacura.ru -> /var/www/clients/client2/web1/
drwxr-x--x 6 web1 client2 4096 Jan  6 16:23 web1

SO: pacura.ru is web1 and belongs to client2, right?

Coincidentally found this by doing a
Code:

tail -f /var/log/ispconfig/httpd/pacura.ru/error.log
Code:

2013/01/11 12:03:19 [error] 28030#0: *3768 FastCGI sent in stderr: "PHP message: PHP Warning:  imagecreatefrompng(): open_basedir restriction in effect. File(/var/www/clients/client1/web3/web/wp-content/plugins/gd-star-rating/stars/oxygen/stars20.png) is not within the allowed path(s): (/var/www/clients/client2/web1/web:/var/www/clients/client2/web1/tmp:/var/www/pacura.ru/web:/srv/www/pacura.ru/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php) in /var/www/clients/client2/web1/web/wp-content/plugins/gd-star-rating/code/gfx/generator.php on line 17
and if I go to ISPCFG panel and edit the site we are talking about, under options it says:
Code:

/var/www/clients/client2/web1/web:/var/www/clients/client2/web1/tmp:/var/www/pacura.ru/web:/srv/www/pacura.ru/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php
How come? No wonder I'm really struggling with multiple problems here :-(
SHall I start from scratch? I haven't done much, just installed the server, moved one website, tested.

till 11th January 2013 20:03

The ispconfig part is fine, the problem is wordpress here,

I guess that you had this wordpressinstance installed before, so its a migrated website or at least some of the wordpressdatabase contents are from a existing install. Wordpress saves paths in its database and the wrong path that you see in the error.log is set inside the wordpress database. You can search the wrong path with e.g. phpmyadmin and ajust it in the wordpess db.

Ovidiu 12th January 2013 11:29

Very well spotted. THat was the problem indeed. I'm setting up a new server and had migrated one single wordpress site to do all the tests and had overlooked hardcoded server names, paths and IPs but I'm currently manually double checking for all of those!


All times are GMT +2. The time now is 12:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.