HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   AutoResponder not using relayhost (http://www.howtoforge.com/forums/showthread.php?t=60168)

wa0ojs 9th January 2013 02:14

AutoResponder not using relayhost
 
The autoresponder fails to use the relay. Emails can be successfully sent and received through a relay host. However, when autoresponder is activated it fails to send the response through the relayhost. Therefore, the email is rejected by the server since it is not on the whitelist.

Any ideas?

Ron

till 9th January 2013 09:10

Please post the lines from mail.log for the delivery of the autoresponder email and the lines for the delivery of a normal email sent trough the relayhost.

wa0ojs 12th January 2013 17:19

AutoResponder not using relay host Mail.LOG
 
Here is the mail.log from a message sent from the server and an incoming email that was to have an autoresponse.

Thanks for your help.

Ron

Mail sent from Mailbox on server:

Jan 12 06:45:25 server postfix/smtp[14471]: 929223E0976: to=<XXXXXX@stx.rr.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.94, delays=0.15/0.06/0.01/0.72, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 5C7A63E099C)
Jan 12 06:45:25 server postfix/qmgr[11344]: 929223E0976: removed
Jan 12 06:45:26 server postfix/smtp[14481]: 5C7A63E099C: to=<XXXXXX@stx.rr.com>, relay=smtp.ch3.comcast.net[76.96.107.76]:25, delay=1.6, delays=0.1/0.06/0.59/0.82, dsn=2.0.0, status=sent (250 2.0.0 mzlR1k00F3Wtfvo01zlS8B mail accepted for delivery)
Jan 12 06:45:26 server postfix/qmgr[11344]: 5C7A63E099C: removed

Mail received and autoresponse enabled.

Jan 12 06:47:14 server postfix/smtpd[14493]: connect from hrndva-omtalb.mail.rr.com[71.74.56.122]
Jan 12 06:47:14 server postfix/smtpd[14493]: 39ED93E0976: client=hrndva-omtalb.mail.rr.com[71.74.56.122]
Jan 12 06:47:14 server postfix/cleanup[14500]: 39ED93E0976: message-id=<20130112114714.X6NH1.6053.root@hrndva-web06-z02>
Jan 12 06:47:14 server postfix/qmgr[11344]: 39ED93E0976: from=<XXXXXX@stx.rr.com>, size=1197, nrcpt=1 (queue active)
Jan 12 06:47:14 server amavis[7534]: (07534-03) NOTICE: reconnecting in response to: err=2006, HY000, DBD::mysql::st execute failed: MySQL server has gone away at (eval 100) line 166, <GEN68> line 5.
Jan 12 06:47:15 server postfix/smtpd[14505]: connect from localhost[127.0.0.1]
Jan 12 06:47:15 server postfix/smtpd[14505]: 23C9D3E099C: client=localhost[127.0.0.1]
Jan 12 06:47:15 server postfix/cleanup[14500]: 23C9D3E099C: message-id=<20130112114714.X6NH1.6053.root@hrndva-web06-z02>
Jan 12 06:47:15 server postfix/qmgr[11344]: 23C9D3E099C: from=<XXXXXX@stx.rr.com>, size=1727, nrcpt=1 (queue active)
Jan 12 06:47:15 server postfix/smtpd[14505]: disconnect from localhost[127.0.0.1]
Jan 12 06:47:15 server amavis[7534]: (07534-03) Passed CLEAN, [71.74.56.122] [71.74.56.122] <XXXXXX@stx.rr.com> -> <XXXXXX@XXXXX.dyndns-XXXXXX.com>, Message-ID: <20130112114714.X6NH1.6053.root@hrndva-web06-z02>, mail_id: xdPOtZnHUeKy, Hits: -0.01, size: 1196, queued_as: 23C9D3E099C, 867 ms
Jan 12 06:47:15 server postfix/smtp[14501]: 39ED93E0976: to=<XXXXXXXX@XXXXX.dyndns-XXXXXX.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.1, delays=0.15/0.03/0/0.87, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 23C9D3E099C)
Jan 12 06:47:15 server postfix/qmgr[11344]: 39ED93E0976: removed
Jan 12 06:47:15 server postfix/pickup[13410]: 7662B3E09CA: uid=5000 from=<>
Jan 12 06:47:15 server postfix/cleanup[14500]: 7662B3E09CA: message-id=<20130112114715.7662B3E09CA@server.XXXXX.dyndns-XXXXXX.com>
Jan 12 06:47:15 server postfix/qmgr[11344]: 7662B3E09CA: from=<>, size=733, nrcpt=1 (queue active)
Jan 12 06:47:15 server postfix/pipe[14506]: 23C9D3E099C: to=<XXXXXXXX@XXXXX.dyndns-XXXXXX.com>, relay=maildrop, delay=0.42, delays=0.09/0.01/0/0.32, dsn=2.0.0, status=sent (delivered via maildrop service)
Jan 12 06:47:15 server postfix/qmgr[11344]: 23C9D3E099C: removed
Jan 12 06:47:16 server postfix/smtpd[14505]: connect from localhost[127.0.0.1]
Jan 12 06:47:16 server postfix/smtpd[14505]: 2457B3E099C: client=localhost[127.0.0.1]
Jan 12 06:47:16 server postfix/cleanup[14500]: 2457B3E099C: message-id=<20130112114715.7662B3E09CA@server.XXXXX.dyndns-XXXXXX.com>
Jan 12 06:47:16 server postfix/qmgr[11344]: 2457B3E099C: from=<>, size=1233, nrcpt=1 (queue active)
Jan 12 06:47:16 server postfix/smtpd[14505]: disconnect from localhost[127.0.0.1]
Jan 12 06:47:16 server amavis[30830]: (30830-05) Passed CLEAN, <> -> <XXXXXX@stx.rr.com>, Message-ID: <20130112114715.7662B3E09CA@server.XXXXX.dyndns-XXXXXX.com>, mail_id: Vj2TG5uYcPNe, Hits: -0.001, size: 733, queued_as: 2457B3E099C, 675 ms
Jan 12 06:47:16 server postfix/smtp[14501]: 7662B3E09CA: to=<XXXXXX@stx.rr.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.8, delays=0.11/0/0/0.68, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 2457B3E099C)
Jan 12 06:47:16 server postfix/qmgr[11344]: 7662B3E09CA: removed
Jan 12 06:47:16 server postfix/smtp[14517]: 2457B3E099C: to=<XXXXXX@stx.rr.com>, relay=smtp.ch3.comcast.net[76.96.107.76]:25, delay=0.73, delays=0.06/0.04/0.46/0.17, dsn=5.1.0, status=bounced (host smtp.ch3.comcast.net[76.96.107.76] said: 550 5.1.0 <> sender rejected: invalid sender domain (in reply to MAIL FROM command))
Jan 12 06:47:16 server postfix/qmgr[11344]: 2457B3E099C: removed
Jan 12 06:47:19 server postfix/smtpd[14493]: disconnect from hrndva-omtalb.mail.rr.com[71.74.56.122]

wa0ojs 17th January 2013 19:43

Autoresponder not using relay host?
 
Any ideas on why it bypasses the relayhost?

ROn


All times are GMT +2. The time now is 13:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.