HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   open_basedir restriction in effect... not for the good site! (http://www.howtoforge.com/forums/showthread.php?t=60163)

lollollollol 8th January 2013 15:30

open_basedir restriction in effect... not for the good site!
 
Hello,
Debian 7 Ispconfig 3.0.4.6

Usually I know how to handle with this kind of message, but here... I don't.

I move an old installation from Debian 6 to Debian 7.
Everything is working fine exept for one site:

Code:

File(/var/www/clients/client1/web3/etc.) is not within the allowed path(s):
Code:

in /var/www/clients/client1/web2/etc.
Complete example:
Code:


       
Code:

       
[Tue Jan 08 14:20:32 2013] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: PHP Warning:  file_exists(): open_basedir restriction in effect. File(/var/www/clients/client1/web3/web/wiki.debian-fr/extensions/SemanticForms/skins/collapse-minus.png) is not within the allowed path(s): (/var/www/clients/client1/web2/web:/var/www/clients/client1/web2/tmp:/var/www/isalo.org/web:/srv/www/isalo.org/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php:/var/www/clients/client1/web2/web/wiki.debian-fr/resources/jquery.ui/themes/default/images/) in /var/www/clients/client1/web2/web/wiki.debian-fr/includes/resourceloader/ResourceLoaderFileModule.php on line 651, referer: http://www.isalo.org/wiki.debian-fr/index.php?title=Images_pour_firmwares_non_reconnus


I found in my error.logs plenty of this warn.
I can't figure why it is looking for web3 while the referer is in web2...

I search for web3 in all files in /client1/web2: nothing.
I also grep all the database, nothing.

I hang this problem for two weeks without finding a solution, it is very annoying ...
If a kind soul would help me I would be delighted! ;)

till 8th January 2013 15:37

The missing file / wrong path is for a graphics file, it might be that the path is defined in the database of this site and not in a file.

lollollollol 8th January 2013 16:54

Bravo.
So I looked bad, like an idiot (phpmyadmin gave me ... binary outcomes).
Search in a terminal was much more efficient.

My logs are finally clean! Thank you very much Till.
Solved.


All times are GMT +2. The time now is 04:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.