HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   possible bug? or problem of my server? (http://www.howtoforge.com/forums/showthread.php?t=60125)

enzolarosa 6th January 2013 10:33

possible bug? or problem of my server?
 
Hi all .. vincenzo 21 years I have used a couple of months ISPConfig .. I'm trying the 3.0.5;) and I'm fine .. trovanto if it were not for a small problem .. after the upgrade (from 3.0.4 to 3.0.5) when I try to add a database from ISPConfig is not actually created in mysql server, however, is shown in the panel .. also subdomains are added to the panel but are not really created .. : (How can I solve .. then there is another problem with cronjob .. below the log ..


Code:

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.

FATAL: Could not load /lib/modules/3.2.13-grsec-xxxx-grs-ipv6-64/modules.dep: No such file or directory
Failed to load mptctl

Error: (CLI:003) Specified controller does not exist.


till 6th January 2013 18:56

Most likely a problem on your server as I know several companys that use 3.0.5 RC1 in production already without any issues. See here for instructions to debug this issue on your server:

http://www.howtoforge.com/forums/showthread.php?t=58408

enzolarosa 6th January 2013 20:16

use Debian 6 and ISPConfig 3.0.5 RC1 -
I followed the guide http://www.faqforge.com/linux/debugg...-of-a-failure/ to doing

crontab -e

and after
/usr/local/ispconfig/server/server.sh

and I get

root@ks3097509:~# crontab -e
crontab: installing new crontab
root@ks3097509:~# /usr/local/ispconfig/server/server.sh
finished.
root@ks3097509:~#

till 6th January 2013 20:45

Seems as if you did not set loglevel to debug asd ecsribe din the faq,otherwise the output of the script would have been more verbose.

enzolarosa 6th January 2013 20:53

how i can set loglevel to debug? :)

enzolarosa 6th January 2013 20:57

i have set debug mode into ispconfig panel.. have run the comand

/usr/local/ispconfig/server/server.sh

and i get this


06.01.2013-19:54 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
06.01.2013-19:54 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

till 6th January 2013 21:03

Thats ok, according to the output there are no pending items or errors. Have you checked if the missing items arecreated now?

enzolarosa 6th January 2013 21:15

if I look in the database that tells me the control panel ISPConfig 3.0.5RC1 tells me that the database exists and is properly c2_seo created .. but if I look in phpmyadmin the database does not exist .. and the same thing for me I created a subdomain subdomain seo. {site} with no redirect flag .. but does not work .. first everything was working properly .. :): (Attached the two screen

http://www.vincenzolarosa.it/wp-cont...-ispconfig.png

http://www.vincenzolarosa.it/wp-cont...phpmyadmin.png

till 6th January 2013 21:41

Did you create a db user for this database first? Database users and databases are now separated in ispconfig. Are there any pending jobs listed in the jobqueue in ispconfig? Have you edited or removed any records in the ispconfig database, especially the sys_datalog table?

Regarding the subdomain, subdomains exist only as config line in the apache vhos of the website were it belongs to, there are no separate files or folders. Have you chakcked the apache vhost of the website were it belongs to if there is a Alias line inside for the subdomain?

enzolarosa 6th January 2013 21:49

yes i have create first user for this database and i call c2_seo...
in pending jobs listed in the jobqueue is empy..
you have removed all of the records in the table that I have indicated .. but I removed them long ago .. I would not be a problem with that ..
vhost file is not present in the line with the subdomain .. or rather there are any other subdomain created before touching the table in question .. : (


All times are GMT +2. The time now is 02:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.