HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Debian not using all available ram (http://www.howtoforge.com/forums/showthread.php?t=60093)

KenKnight 3rd January 2013 02:25

Debian not using all available ram
 
Hi all,

I setup a Debian Perfect server a couple of years ago and we just caught recently that it is not utilizing all the available ram. This server (Dell 1750) has 2 gigs of ram which is verified by the lshw results below.



Code:

======== LSWH =========
root@mail:/etc/default# lshw -C memory
  *-firmware
      description: BIOS
      vendor: Dell Computer Corporation
      physical id: 0
      version: A12 (09/29/2006)
      size: 64KiB
      capacity: 4032KiB
      capabilities: isa pci pnp upgrade shadowing escd cdboot bootselect edd int13floppytoshiba int13floppy360 int13floppy1200 int13floppy720 int9keyboard int14serial int10video acpi usb ls120boot biosbootspecification netboot
  *-cache:0
      description: L1 cache
      physical id: 700
      size: 8KiB
      capacity: 8KiB
      capabilities: internal write-back data
  *-cache:1
      description: L2 cache
      physical id: 701
      size: 512KiB
      capacity: 1MiB
      capabilities: internal varies unified
  *-cache:0
      description: L1 cache
      physical id: 703
      size: 8KiB
      capacity: 8KiB
      capabilities: internal write-back data
  *-cache:1
      description: L2 cache
      physical id: 704
      size: 512KiB
      capacity: 1MiB
      capabilities: internal varies unified
  *-memory
      description: System Memory
      physical id: 1000
      slot: System board or motherboard
      size: 2GiB
    *-bank:0
          description: DIMM DDR Synchronous 266 MHz (3.8 ns)
          physical id: 0
          slot: DIMM_1A
          size: 1GiB
          width: 64 bits
          clock: 266MHz (3.8ns)
    *-bank:1
          description: DIMM DDR Synchronous 266 MHz (3.8 ns)
          physical id: 1
          slot: DIMM_1B
          size: 1GiB
          width: 64 bits
          clock: 266MHz (3.8ns)
    *-bank:2
          description: DIMM DDR Synchronous 266 MHz (3.8 ns) [empty]
          physical id: 2
          slot: DIMM_2A
          width: 64 bits
          clock: 266MHz (3.8ns)
    *-bank:3
          description: DIMM DDR Synchronous 266 MHz (3.8 ns) [empty]
          physical id: 3
          slot: DIMM_2B
          width: 64 bits
          clock: 266MHz (3.8ns)


free -m
Code:

root@mail:/etc/default# free -m
            total      used      free    shared    buffers    cached
Mem:          248        244          4          0          5        33
-/+ buffers/cache:        205        42
Swap:          484        175        309

We've tried putting mem=2048 in the grub file but that isn't working.

Code:

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
#GRUB_CMDLINE_LINUX=""
GRUB_CMDLINE_LINUX="var1 var2 mem=2048m"


The uname info is:

Code:

root@mail:/etc/default# uname -a
Linux mail.pboss.com 2.6.32-5-686 #1 SMP Tue Mar 8 21:36:00 UTC 2011 i686 GNU/Linux

Is this a bigmem issue or does anyone have any other suggestions?

Thanks,
Ken

falko 3rd January 2013 15:30

What's the output of
Code:

cat /proc/meminfo
?

KenKnight 7th January 2013 21:47

Thanks falko,

Here's the info;

Code:

MemTotal:        254508 kB
MemFree:            6916 kB
Buffers:          14484 kB
Cached:            40984 kB
SwapCached:        45968 kB
Active:            98024 kB
Inactive:        121536 kB
Active(anon):      73864 kB
Inactive(anon):    90260 kB
Active(file):      24160 kB
Inactive(file):    31276 kB
Unevictable:          0 kB
Mlocked:              0 kB
HighTotal:            0 kB
HighFree:              0 kB
LowTotal:        254508 kB
LowFree:            6916 kB
SwapTotal:        496632 kB
SwapFree:        120488 kB
Dirty:                4 kB
Writeback:            0 kB
AnonPages:        119220 kB
Mapped:            8300 kB
Shmem:                20 kB
Slab:              13832 kB
SReclaimable:      5348 kB
SUnreclaim:        8484 kB
KernelStack:        2480 kB
PageTables:        4340 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:      623884 kB
Committed_AS:    1220324 kB
VmallocTotal:    766108 kB
VmallocUsed:        9064 kB
VmallocChunk:    736976 kB
HardwareCorrupted:    0 kB
HugePages_Total:      0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:      4096 kB
DirectMap4k:      12124 kB
DirectMap4M:      249856 kB


falko 9th January 2013 11:19

The server is in fact using 248MB of RAM. Please double-check if there are really 2GB of RAM, and if so, if they are ok (maybe you need to replace it).

KenKnight 9th January 2013 13:42

Thanks falko, we'll do. There truly is 2GB recognized by the bios. You can see in my first post for this thread, the lswh result for bank 0 and bank 1 have 1GB chips in them.

Cheers!
Ken

KenKnight 9th January 2013 21:55

I personally believe it has to be a configuration or kernel issue. We took another PE1750 (identical) down to the data center with 4 gigs in it and pull the hard drives from the original server and put them in the other server. It is now reading 2GB. This is certainly better than 256meg, but doesn't explain why the O/S doesn't see all the memory... regardless of whether it can use it.

Thanks,
Ken

KenKnight 27th March 2013 21:23

MYSTERY SOLVED!!!!

Hi all,

Been a while since I'd worked on this, but I decided to rebuild the original server that was brought back from the data center (the one reporting the 256megs) and figured out what was causing it. Someone flipped the "OS Install Mode" to "ON" in the BIOS. This limited the memory to 256megs. What a PITA!

Anyway, toggling that off and rebooting caused the OS to see all the memory.

Hope this helps someone else.

Cheers!
Ken


All times are GMT +2. The time now is 09:11.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.