HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   New Member / ISP Config Error ((Error code: ssl_error_rx_record_too_long)) (http://www.howtoforge.com/forums/showthread.php?t=60076)

kareemhali 31st December 2012 17:03

New Member / ISP Config Error ((Error code: ssl_error_rx_record_too_long))
 
Hi Guys,

I'm a new memeber here and this is my first post. I'm sure this site is as good as it's product, ISPConfig!.

I'm having a problem with my server. My server is a CentOS 6.3 box with ISPConfig 3.0.4.6 installed, with Apache and Dovecot.

I installed an SSL certificate from GoDaddy to use with my site, breezee.com, and the email that we're using with it. Both works more than fine.

Suddenly, I can't login to ISPconfig interface. I was able to login to it for a while after installing the ssl certs and done security stuff with both webserver and mail server, but since yesterday I can't anymore. I tried many things and after restarting I get this error:

(Error code: ssl_error_rx_record_too_long)

Now I did (update.php) again and made sure that all files are referenced to correctly but still no help. I just don't know what could be the cause of this sudden problem as everything was running normal.

Any help please ?

Regards,
Kareem.

till 31st December 2012 19:09

The ssl certificate is either broken or does not exist. Are you able to access ispconfig with http ( not https) on port 8080?

kareemhali 31st December 2012 19:21

Hi,

Thank you for your reply. The system was working fine for more than a week, I used to login everyday to check status and logs from ISPConfig interface. This started yesterday suddenly.

I can't login to http interface too.

Btw, after reboot the SSL error above shows for a while, then after that the error doesn't show again and the page keeps loading for a while until it says:
"The connection to breezee.com:8080 was interrupted while the page was loading."

When the SSL error is showing and I try http://breezee.com:8080 it tells me that I can't use a proxy or something like that, but when the ssl error is not showing and it's taking a while to load then the http page takes a while to load without any output too.

I'm using the same SSL certificate for the site and for ISPconfig, if you go to https://breezee.com and http://breezee.com everything works fire and you can see the certificate data. Shouldn't that mean that the SSL certificate is working fine ?

Kareem.

till 1st January 2013 14:47

Something is wrong with the ssl cert of the ispconfig vhost when you get this error. Please run the ispconfig update.php script again, when the updater asks you to create new ssl certificates for the ispconfig interface, then choose yes.

kareemhali 1st January 2013 23:02

But that would change the key and csr files which is tied to the SSL certificate that I'm using which is not an ISPconfig issued one, right ?

till 2nd January 2013 08:13

Quote:

But that would change the key and csr files which is tied to the SSL certificate that I'm using which is not an ISPconfig issued one, right ?
Yes. But as your current ssl setup is broken so the best way to get it working again is to recreate the certs. If it is working again, you can try to restore the signed ssl certs to see which of the files is not ok.

kareemhali 3rd January 2013 00:11

Hi,

Just did full update.php, nothing works now :(.

Question, GoDaddy gives two files for SSL, one is the certificate_file.crt and the other one is gd_bundle.crt. Do I need to reference both of them in the config files for httpd, postfix, dovecot ?

Also, do I need to reference the key file which the certs were created with?, I used the one in /usr/local/ispconfig/interface/ssl/ispserver.key to create my GoDaddy cert.

Kareem.

kareemhali 3rd January 2013 00:34

I managed to restore the email service and the site, I created new cert files for ISPconfig different from the ones I'm using for my site and I reference to them, still can't login to ISPConfig interface!

kareemhali 3rd January 2013 00:47

This is the error when I try without https:

"HTTP through a proxy server is not allowed."

falko 3rd January 2013 15:25

This should give you the idea: http://www.howtoforge.com/securing-y...-from-startssl


All times are GMT +2. The time now is 00:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.