HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Got a new one here. Permissions and ownership askew (http://www.howtoforge.com/forums/showthread.php?t=60073)

bigmatlem 30th December 2012 22:08

Got a new one here. Permissions and ownership askew
 
ISPConfig 3. When it created the directory for the new site it created it properly and gave it permissions for say web1 client1. However here is the strange part. When it gets done creating that and this just started out of the blue it won't allow anything to be written to the directory structure without changing the ownership to www-data:www-data.

What happened? It is running Ubuntu 12.04.1 LTS Server Edition 64bit. This started today. And nothing that I know of changed.

My guess is that somehow apache user group is messed up and isn't allowing what was work and ignores the ispconfig configurations.

GRRR! Ideas would be greatly appreciated.

till 30th December 2012 23:26

You selected the wrong php mode or did not enable suexec.

1) Change the ownership back to web1;clienbt as itw as before.
2) Set the php mode to "php-fcgi" and enable the suexec checkbox in the website settings.

Btw, thats described in the manual.

bigmatlem 31st December 2012 04:13

fcgi
 
Yeah its not a problem with executing cgi its a problem writing out to the directory. Its creating directories as www-data when the directory is owned by web1. It appears to be picking it up from apache rather than what it should be.

Are you saying that the fcgi will force apache to write as web1...? I did buy the manual by the way.

till 31st December 2012 10:47

Quote:

Its creating directories as www-data when the directory is owned by web1. It appears to be picking it up from apache rather than what it should be.
Enable suexec, you will see that it works then.

Quote:

Are you saying that the fcgi will force apache to write as web1...?
Yes, thats the purpose of the suexec function. But ensure that you switched php mode to php-fcgi, do not use mod_php.


All times are GMT +2. The time now is 15:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.