HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   ISPConfig 3.0.5 RC 1 released for testing (http://www.howtoforge.com/forums/showthread.php?t=60025)

till 21st December 2012 15:30

ISPConfig 3.0.5 RC 1 released for testing
 
The release candidate (RC) of the upcoming ISPConfig 3.0.5 is available for download. RC versions are released for testing purposes and should not be installed on production systems.

What's new in ISPConfig 3.0.5

- APS package installer. See http://www.apsstandard.org for a list of available packages.
- New web backup system which includes the website databases.
- Mailuser login.
- PHP version selector. Use different PHP versions for different websites.
- Subdomains as virtualhost with separate directory inside the directory tree of the main website without rewriting.
- Support for mod_perl2.
- Improved default theme.
- Global search function.
- PHP-FPM support for Apache servers.
- PHP-FPM mode selector in website options.
- Hardened the website folder structure with new folder protection feature and stricter security settings.
- Maintenance mode.
- Password generator.
- Password confirmation fields.
- Directive snippets for Apache, nginx, and PHP can now be saved and be reused for other websites.
- Forms can be submitted by pressing ENTER (you don't have to click the Save button anymore).
- Many more minor feature enhancements and bugfixes.
- IDN domains are converted automatically to / from punicode. (requires PHP idn extension from pecl)
- Mail traffic reporting for dovecot servers.

Special thanks to Marius Cramer from www.pixcept.de for his contributions to the 3.0.5 ISPConfig release.

Detailed Changelog

http://bugtracker.ispconfig.org/inde...&status[]=

Download

http://www.ispconfig.org/downloads/I...0.5-rc1.tar.gz

Update instructions

Code:

cd /tmp
rm -rf /tmp/ispconfig3_install
wget http://www.ispconfig.org/downloads/ISPConfig-3.0.5-rc1.tar.gz
tar xvfz ISPConfig-3.0.5-rc1.tar.gz
cd ispconfig3_install/install
php -q update.php


Petr 21st December 2012 17:04

Hi, I have a small question about APS installation .

is OK this work?

1)
if I have installed one APS in mydomain.ltd/aps1 and new instaled second aps on root ( mydomains.ltd ) - this action remove APS in mydomain.ltd/aps1 too .

2)
I have installed one APS on mydomains.ltd and second in mydomain.ltd/aps1 and remove APS in root ( mydomains.ltd ) - this action remove all APS .

all action install/uninstall I do on APS option page.

thanks, Petr

till 21st December 2012 17:25

This can happen when you install more then one package per website depending on the packagees, file and folder names etc. I will see if we add a option that the admin can disable the ability to install more then one package per site.

renaudmanda 27th December 2012 16:16

APS Installer failed
 
I tried to use the installer to install wordpress 3.5 to the root of a website.

Unfortunately I got "installation_error". When I check in the error.log file I see that wp-load.php tries to access to /var/www/<website>/wp-config.php file instead of /var/www/<website>/web/wp-config.php

Is it an aps installer error or something missconfig on my side ? Where can I check APS installer logs ?

Regards,
Renaud

till 27th December 2012 17:03

I had tested the wordpress install last week and it worked fine at that time. What did you enter into the path field?

Quote:

Where can I check APS installer logs ?
The aps installer has no separate log. See sticky post in thegeneral forum for debug instructions.

renaudmanda 27th December 2012 17:10

Quote:

Originally Posted by till (Post 290040)
I had tested the wordpress install last week and it worked fine at that time. What did you enter into the path field?

I left it empty, because I wanted to install WP at the root.

So in Basic settings on the "Install location" line I had:

Installation location http(s)://<website fqdn> / <field empty>

Renaud

till 27th December 2012 17:12

Thats ok, these are the settings I tested before the RC was released. So maybe the aps package from apsstandard.org was updated or is broken at the moment.

gjm31 28th December 2012 23:42

mine was working fine until update, update completed, now internal server error when trying to connect to ispconfig.

Running centos 6.3 with apache , courier etc.

All working fine as said, but no after update

gjm31 29th December 2012 14:04

heres my server log ;

[Sat Dec 29 12:59:07 2012] [warn] [client 192.168.1.4] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Sat Dec 29 12:59:07 2012] [error] [client 192.168.1.4] Premature end of script headers: index.php

So the problem is fastcgi, and im not sure how to fix it?

till 29th December 2012 17:14

Check that the path to the php cgi binary in the file /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter is correct.


All times are GMT +2. The time now is 10:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.