HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   How to test DNS? (http://www.howtoforge.com/forums/showthread.php?t=59959)

kendel 14th December 2012 22:24

How to test DNS?
 
Is there a way to test internally if the DNS server is working properly. I did http://www.intodns.com/lampxserver.com and have nameserver issues.

My router is forwarding port 53 to ns1 and these are my DNS settings:
Code:

Yes A lampxserver.com. 67.191.52.236 0 
Yes A mail 67.191.52.236 0 
Yes A www 67.191.52.236 0 
Yes MX lampxserver.com. mail1.lampxserver.com. 10 
Yes NS lampxserver.com. ns1.lampxserver.com. 0 
Yes NS lampxserver.com. ns2.lampxserver.com. 0


kendel 15th December 2012 00:01

I figured out that my nameserver are not being resolved internally, how can I fix this... I changed the IP address of the hostname ns1.lampxserver.com to 192.168.10.151 and it now works... Why does it not resolve the internal IP?

almere 15th December 2012 10:41

you can try dig from localhost to extern IP

kendel 15th December 2012 16:53

Does anyone have any mapping guides to go by to efficiently map DNS records to internal server.

kendel 15th December 2012 19:07

One problem I am trying to figure out. Or rather a few problems:

I have my phpmyadmin on my db1 server running an apache instance.
I wish to make ispconfig on the panel server connecter to the phpmyadmin on the db server, how can I do that. one method I tried was:

First removing the /phpmyadmin from ispconfig server configuration then.
Using ssh to open the panel server that has the ispconfig web shell
Code:

nano /usr/local/ispconfig/interface/web/sites/database_phpmyadmin.php


    if($global_config['phpmyadmin_url'] != '') {
        $phpmyadmin_url = $global_config['phpmyadmin_url'];
        $phpmyadmin_url = str_replace('[SERVERNAME]',$serverData['server_name'],$phpmyadmin_url);
        header('Location:'.$phpmyadmin_url);
    } else {
        isset($_SERVER['HTTPS'])? $http = 'https' : $http = 'http';
        $http = 'http'; : just insert this line exactly here.
        if($web_config['server_type'] == 'nginx') {
            header('location:' . $http . '://' . $serverData['server_name'] . ':8081/phpmyadmin');
        } else {
            header('location:' . $http . '://' . $serverData['server_name'] . '/phpmyadmin');
        }
    }

I added the $http = 'http'; then I created an A record for db1 to the internal IP address of the database server which was called db1.domain_name.com

That of course did not work internally on the network or externally.

How can I correct this?

kendel 17th December 2012 04:08

I have a glue record for my domain lampxserver.com but when I create the site and add the DNS records it does not work, here are the results:
http://www.intodns.com/lampxserver.com

But another domain using the same Nameservers ns1.lampxserver.com and ns2.lampxserver.com works fine:
http://www.intodns.com/ahostgroup.com

using the same DNS record settings... Am I not able to use the domain of my name servers? or how can I fix this.


All times are GMT +2. The time now is 02:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.