HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   General (
-   -   Confirmation if this is true. (

kendel 14th December 2012 06:15

Confirmation if this is true.
I am configuring a mailserver but the guide I am following says:

Because the current state of ISPConfig 3 (3.0.4) does not support Dovecot 2.x, we need to handle Dovecot configuration ourselves.

    First confirm Dovecot version :
        mail1 server shell> dpkg -l | grep dovecot : Dovecot is version 2.0.13 on my system.
    Second confirm that Dovecot cannot start :
        mail1 server shell> nmap localhost : check to see which services are running - smtp is running but both pop3 & imap is down (you may need to install nmap).
        mail1 server shell> service dovecot start : it looks like we can start Dovecot, but ..
        mail1 server shell> service dovecot status : .. actually we cannot.
    Ok, time to reconfigure Dovecot. There are so many changes needed that it is most easy to rewrite the /etc/dovecot/dovecot.conf file from scratch. Here is the full dovecot.conf file as it should look like :
        !include_try /usr/share/dovecot/protocols.d/*.protocol
        !include conf.d/*.conf.
        mail_location = maildir:/var/vmail/%d/%n/Maildir : overwrite the default mail_location value. %d is domain, %n is account.
        (email messages to will be stored in /home/vmail/
        disable_plaintext_auth = no : otherwise I cannot get Gmail POP3 integration to work.
        namespace {
            type = private : this namespace contains only the users own mailboxes. (there are also shared and public types).
            separator = . : char for separating child folders, eg. or work.programming.
            prefix = INBOX.
            inbox = yes : this namespace contains the inbox (there are only one inbox).
        protocol lda { : we need to overwrite the protocol lda setting in conf.d/01-mail-stack-delivery.conf
            auth_socket_path = /var/run/dovecot/auth-master : UNIX socket path to Dovecot LDA.
            postmaster_address = root@localhost : here it may be better to use your own email address
            mail_plugins = sieve
            log_path = /var/vmail/dovecot-deliver.log : ISPConfig creates the /var/vmail base directory
            deliver_log_format = msgid=%m: %$
            rejection_reason = Your message to <%t> was automatically rejected:%n%r
        auth default {
            user = root
            mechanisms = plain login
            passdb sql {
                args = /etc/dovecot/dovecot-sql.conf
            userdb static {
                args = uid=5000 gid=5000 home=/var/vmail/%d/%n allow_all_users=yes
            socket listen {
                master { : master socket gives access to userdb information typically so the Dovecot LDA can find mailbox locations
                    path = /var/run/dovecot/auth-master
                    mode = 0600
                    user = vmail
                client {
                    path = /var/spool/postfix/private/auth : tells Dovecot where to communicate with Postfix authentication.
                    mode = 0660 : tells Dovecot that there are read & write access.
                    user = postfix : tells Dovecot to use the postfix user for access.
                    group = postfix : tells Dovecot use the postfix group for access.

Before I made those changes I wanted to confirm, this is the current content of that file:

nano /etc/dovecot/dovecot.conf

protocols = imap pop3
auth_mechanisms = plain login
disable_plaintext_auth = no
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_privileged_group = vmail
ssl_cert = </etc/postfix/smtpd.cert
ssl_key = </etc/postfix/smtpd.key
passdb {
  args = /etc/dovecot/dovecot-sql.conf
  driver = sql
userdb {
  args = /etc/dovecot/dovecot-sql.conf
  driver = sql
plugin {
  quota = dict:user::file:/var/vmail/%d/%n/.quotausage
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  unix_listener auth-userdb {
    group = vmail
    mode = 0600
    user = vmail
  user = root
protocol imap {
  mail_plugins = quota imap_quota
protocol pop3 {
  pop3_uidl_format = %08Xu%08Xv
  mail_plugins = quota
protocol lda {
  mail_plugins = sieve quota

Should I replace the code?

till 14th December 2012 09:30


Should I replace the code?
No. The current ispconfig version supports dovecot 1.2 and also dovecot 2. The current content of the file is correct, so dont change it or you will break your imap server too.

kendel 14th December 2012 15:13

How do you fix the issue in the Server List where they always show warning: I have tried update and upgrade then a reboot, but it never fixes...
It always says something needs an update.
display: Warning

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
linux-headers-3.2.0-34 linux-headers-3.2.0-34-generic
The following packages will be upgraded:
linux-headers-server linux-image-server linux-server
3 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-3.2.0-34-generic (3.2.0-34.53 Ubuntu:12.04/precise-updates [amd64])
Inst linux-headers-3.2.0-34 (3.2.0-34.53 Ubuntu:12.04/precise-updates [all])
Inst linux-headers-3.2.0-34-generic (3.2.0-34.53 Ubuntu:12.04/precise-updates [amd64])
Inst linux-headers-server [] ( Ubuntu:12.04/precise-updates [amd64])
Inst linux-server [] ( Ubuntu:12.04/precise-updates [amd64]) []
Inst linux-image-server [] ( Ubuntu:12.04/precise-updates [amd64])
Conf linux-image-3.2.0-34-generic (3.2.0-34.53 Ubuntu:12.04/precise-updates [amd64])
Conf linux-headers-3.2.0-34 (3.2.0-34.53 Ubuntu:12.04/precise-updates [all])
Conf linux-headers-3.2.0-34-generic (3.2.0-34.53 Ubuntu:12.04/precise-updates [amd64])
Conf linux-headers-server ( Ubuntu:12.04/precise-updates [amd64])
Conf linux-image-server ( Ubuntu:12.04/precise-updates [amd64])
Conf linux-server ( Ubuntu:12.04/precise-updates [amd64])

till 14th December 2012 15:27


apt-get update
apt-get upgrade

The status in ispconfig will get updated then within 24 hours. If not, then your cron daemon might not be running or there is a issue with the commandline php binary e.g. that some functions are disabled. See here for debug instructions for that case:

All times are GMT +2. The time now is 00:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.