HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Multiserver (http://www.howtoforge.com/forums/showthread.php?t=59910)

almere 11th December 2012 10:26

Multiserver
 
Hi,

I have to servers.

First - s1.
Second - s2.

At s1 i have ISPConfig 3.0.5 (Beta 1) running, and i want to add a new server, so that i can manage all servers from s1 (i want to manage server s2 and lateer s3,4,5 from s1). What i did:

Installed everything, like here at s2: http://www.howtoforge.com/perfect-se...ispconfig-3-p6. But i choose expert mode and tried to connect to s1. But it didn't succeed.

I tried mysql -h s1.example.com -u root -p (Entered right password), but i get:
ERROR 1130 (HY000): Host 's1.example.com' is not allowed to connect to this MySQL server

What i did wrong?

till 11th December 2012 10:53

Did you add 2 mysql root users on the master mysql server, the first one that is allowed to connect from the hostname of the slave and the second one which is allowed to connect from the Ip address of the slave as described in the multiserver setup guides? And di you change the /etc/hosts files on both servers as described in the multiserver setup guides so that they contain lines for the hostname of all servers that are part of this setup?

edge 11th December 2012 11:05

Verry off topic, but I love your forum name.
Almere... It's the name of the placed that I live in :-)

i11usions 11th December 2012 19:28

you should create sql users in the master database

CREATE USER 'root'@'s2' IDENTIFIED BY 'myrootpassword';
GRANT ALL PRIVILEGES ON * . * TO 'root'@'s2' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;

almere 11th December 2012 19:48

i11usions, till thank you guys. I managed it my self. Now it works.

I saw a thread, where some person had a problem with monitoring of multiservers. Its true. I installed it and i can see Overview, but not Server State (system load, disk usage etc.). I have Debian squeeze on both of my servers.
Maybe you have some advices about it?

Thank you.

edge, check your ls :)

till 11th December 2012 21:03

The most likely reason for this problem is that you did not had configured the /etc/hosts files correcrly on both servers before you installed ispconfig on the slave server. If the configuration is was not correct, ispconfig is not able to connect to the master later to replicate chnages and update the monitor. Take a look at the multiserver tutorials, the configuration is described there.


All times are GMT +2. The time now is 17:03.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.