HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Error configuring suPHP mod (http://www.howtoforge.com/forums/showthread.php?t=59909)

cgavin11 10th December 2012 19:56

Error configuring suPHP mod
 
Trying to follow: http://www.howtoforge.com/perfect-se...ispconfig-3-p4 and when i get to building suPHP mod with:
./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=owner --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes

I get the following error:

checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a
build directory, or an apr-config file.

Has anyone got this or seen this?

falko 12th December 2012 10:29

Does /usr/bin/apr-1-config exist?

cgavin11 12th December 2012 14:50

Yes it does exist.

falko 14th December 2012 18:16

Did you disable SELinux?

comintech 30th December 2012 03:36

Same problem here
 
Hello,
I have same problem when trying to configure suPHP for compilation, selinux is disabled and /usr/abin/apr-1-config is present.
Will appreciate any help!
Thanks!
Happy holidays!


All times are GMT +2. The time now is 09:03.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.