HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   dovecot problem after ISPCONFIG (http://www.howtoforge.com/forums/showthread.php?t=59899)

Hasanov 9th December 2012 11:35

dovecot problem after ISPCONFIG
 
I went through step-by-step installation guide and did everything that had to be done to install ISPconfig on my new centos 5.8 server. There is just one problem and that is Dovecot is not installed. When I try to install again it shows some missing dependencies... AND one more thing from where I can get GPG key for ATrpms repository.. Thanks..

http://s10.postimage.org/r1zbfmy7d/fail.png

Code:

[root@baki ~]# yum install dovecot dovecot-sieve
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * atomic: mir01.syntis.net
 * base: mirror.ovh.net
 * centosplus: mirror.ovh.net
 * contrib: mirror.ovh.net
 * extras: mirror.ovh.net
 * rpmforge: archive.cs.uu.nl
 * updates: mirror.ovh.net
Excluding Packages in global exclude list
Finished
Excluding Packages from Red Hat Enterprise Linux 5 - x86_64 - ATrpms
Finished
Reducing Red Hat Enterprise Linux 5 - x86_64 - ATrpms to included packages only
Finished
Excluding Packages from Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing
Finished
Reducing Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing to included packages only
Finished
Excluding Packages from CentOS-5 - Base
Finished
Reducing CentOS-5 - Plus to included packages only
Finished
Excluding Packages from CentOS-5 - Updates
Finished
Setting up Install Process
No package dovecot-sieve available.
Resolving Dependencies
--> Running transaction check
---> Package dovecot.x86_64 1:1.0.15-1_74.el3 set to be updated
--> Processing Dependency: libpq.so.3()(64bit) for package: dovecot
--> Processing Dependency: libmysqlclient.so.10()(64bit) for package: dovecot
--> Processing Dependency: libldap.so.2()(64bit) for package: dovecot
--> Processing Dependency: liblber.so.2()(64bit) for package: dovecot
--> Finished Dependency Resolution
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: libmysqlclient.so.10()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: libldap.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: libpq.so.3()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
1:dovecot-1.0.15-1_74.el3.x86_64 from atrpms has depsolving problems
  --> Missing Dependency: liblber.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: libldap.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: libpq.so.3()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: libmysqlclient.so.10()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
Error: Missing Dependency: liblber.so.2()(64bit) is needed by package 1:dovecot-1.0.15-1_74.el3.x86_64 (atrpms)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

BTW. I'm a total newbie to linux but not an idiot. So if you guys can show me around, I will be able to know what to do. Thank you all in advance, kind regards!

falko 10th December 2012 10:57

Which tutorial (URL) did you use? What are the outputs of
Code:

netstat -tap
,
Code:

iptables -L
, and
Code:

getconfig
?

Hasanov 11th December 2012 21:33

Quote:

Originally Posted by falko (Post 289432)
Which tutorial (URL) did you use?

I used tutorial for ISPconfig 3 installation for CentOS 5.7 - http://www.howtoforge.com/perfect-se...64-ispconfig-3

Quote:

Originally Posted by falko (Post 289432)
What are the outputs of
Code:

netstat -tap

Code:

[root@baki ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address              Foreign Address            State      PID/Program name 
tcp        0      0 localhost.localdomain:10024 *:*                        LISTEN      14306/amavisd (mast
tcp        0      0 *:mysql                    *:*                        LISTEN      5416/mysqld       
tcp        0      0 localhost.local:dyna-access *:*                        LISTEN      14323/clamd       
tcp        0      0 *:sunrpc                    *:*                        LISTEN      3899/portmap       
tcp        0      0 *:721                      *:*                        LISTEN      3931/rpc.statd     
tcp        0      0 baki.***.net:domain      *:*                        LISTEN      3970/named         
tcp        0      0 localhost.localdomai:domain *:*                        LISTEN      3970/named         
tcp        0      0 *:ftp                      *:*                        LISTEN      14352/pure-ftpd (SE
tcp        0      0 *:ssh                      *:*                        LISTEN      3021/sshd         
tcp        0      0 localhost.localdomain:smtp  *:*                        LISTEN      5577/master       
tcp        0      0 localhost.localdomain:rndc  *:*                        LISTEN      3970/named         
tcp        0    976 baki.***.net:ssh          MYREALIP:61779          ESTABLISHED 18640/sshd         
tcp        0      0 *:webcache                  *:*                        LISTEN      4955/httpd         
tcp        0      0 *:http                      *:*                        LISTEN      4955/httpd         
tcp        0      0 *:tproxy                    *:*                        LISTEN      4955/httpd         
tcp        0      0 *:domain                    *:*                        LISTEN      3970/named         
tcp        0      0 *:ftp                      *:*                        LISTEN      14352/pure-ftpd (SE
tcp        0      0 *:ssh                      *:*                        LISTEN      3021/sshd         
tcp        0      0 ::1:rndc                    *:*                        LISTEN      3970/named         
[root@baki ~]#

Quote:

Originally Posted by falko (Post 289432)
What are the outputs of
Code:

iptables -L

Code:

[root@baki ~]# iptables -L
Chain INPUT (policy ACCEPT)
target    prot opt source              destination       

Chain FORWARD (policy ACCEPT)
target    prot opt source              destination       

Chain OUTPUT (policy ACCEPT)
target    prot opt source              destination       
[root@baki ~]#

Quote:

Originally Posted by falko (Post 289432)
What are the outputs of
Code:

getconfig
?

Code:

[root@baki ~]# getconfig
-bash: getconfig: command not found
[root@baki ~]#


falko 12th December 2012 10:36

Quote:

Originally Posted by Hasanov (Post 289404)
AND one more thing from where I can get GPG key for ATrpms repository.. Thanks..

Just run
Code:

wget http://ATrpms.net/RPM-GPG-KEY.atrpms
rpm --import RPM-GPG-KEY.atrpms

Can you run
Code:

/etc/init.d/dovecot start
? Does it work then? If not, what's the output of
Code:

uname -a
?

Hasanov 12th December 2012 16:53

Quote:

Originally Posted by falko (Post 289524)
Just run
Code:

wget http://ATrpms.net/RPM-GPG-KEY.atrpms
rpm --import RPM-GPG-KEY.atrpms


Code:

[root@baki ~]# wget http://ATrpms.net/RPM-GPG-KEY.atrpms
--2012-12-12 16:49:52--  http://atrpms.net/RPM-GPG-KEY.atrpms
Resolving atrpms.net... 160.45.254.26
Connecting to atrpms.net|160.45.254.26|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-12-12 16:49:52 ERROR 404: Not Found.

[root@baki ~]# rpm --import RPM-GPG-KEY.atrpms
error: RPM-GPG-KEY.atrpms: import read failed(-1).
[root@baki ~]#


Quote:

Originally Posted by falko (Post 289524)

Can you run
Code:

/etc/init.d/dovecot start
? Does it work then?

Code:

[root@baki ~]# /etc/init.d/dovecot start
-bash: /etc/init.d/dovecot: No such file or directory
[root@baki ~]#

Quote:

Originally Posted by falko (Post 289524)
If not, what's the output of
Code:

uname -a
?

Code:

[root@baki ~]# uname -a
Linux baki.***.net 3.2.13-grsec-xxxx-grs-ipv6-64 #1 SMP Thu Mar 29 09:48:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@baki ~]#

it's just it does not install dovecot because of missing dependencies that are mentioned in my first post..

Hasanov 13th December 2012 17:53

it will sound stupid, but i just updated ISPconfig (through ssh) and everything works perfectly now.. dovecot runs too


All times are GMT +2. The time now is 17:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.