HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig 3.0.5 and PHP 3.4* Stable (http://www.howtoforge.com/forums/showthread.php?t=59891)

sjswarts 7th December 2012 02:58

ISPConfig 3.0.5 and PHP 3.4* Stable
 
Hi guys,

Server Details:

Debian 6 Squeeze
Horde 5
ISPConfig 3.0.4.6
Postfix
Dovecot
Apache2
Bind
PHP 3.3.3-7

Recently Horde released an IMAP module that "broke" the log in access - read about it here http://bugs.horde.org/ticket/11824 - now it becomes apparent that PHP 3.3.3 is actually an old version and that PHP 3.4.* is the latest stable.

My question is simple - Can I upgrade without losing access to databases, etc my ISPConfig 3.0.4.6 and in the future upgrade to 3.0.5 ??

Cheers,
Steven Swarts

falko 7th December 2012 08:22

I guess you mean PHP 5.3 and 5.4? The problem is that Debian Squeeze doesn't offer any newer PHP versions.

sjswarts 10th December 2012 07:09

Correct my error.

Code:

root@mail:~# php -v
PHP 5.3.3-7+squeeze14 with Suhosin-Patch (cli) (built: Aug  6 2012 14:18:06)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
root@mail:~#

I understand that PHP 5.4 isn't released under the Debian standard sources however is there a method for updating it via other sources? If so would it break ISPConfig 3?

falko 12th December 2012 10:18

You might want to check out the dotdeb repo: http://www.dotdeb.org/

However, I can't say if it will break your system or not.

sjswarts 19th December 2012 17:20

I'll try it out on my test server.
Thanks for the help falko


All times are GMT +2. The time now is 14:41.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.