HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Horde 5 Task issue - ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=59847)

sjswarts 4th December 2012 02:34

Horde 5 Task issue - ISPConfig 3
 
G'day guys,

I have an issue with Horde 5 (already tried dealing with their support) Nag component to Horde Webmail Groupware.

Server:
Debian 6 Squeeze
ISPConfig 3.0.4.6
VPS
Dovecot, Apache2, Postfix, Bind
Horde is installed in directory /var/www/horde

The issue is related solely to the Nag module of Horde 5 as the rest have no issue (IMP, etc).

What happens is that when I try to create a New task it fails in the redirect.

This is taken from the log of Apache:

Code:

[Fri Nov 30 12:20:18 2012] [error] [client 91.149.61.36] File does not exist: /var/www/horde/nag/t, referer: https://www.example.com/horde/nag/task.php?actionID=add_task
This is my horde.conf

Code:

Alias /autodiscover/autodiscover.xml /var/www/horde/rpc.php
Alias /Microsoft-Server-ActiveSync /var/www/horde/rpc.php

Alias /Autodiscover/Autodiscover.xml /var/www/horde/rpc.php
#Alias /autodiscover/autodiscover.xml /var/www/horde/rpc.php
Alias /AutoDiscover/AutoDiscover.xml /var/www/horde/rpc.php

Alias /horde /var/www/horde
Alias /webmail /var/www/horde

<Directory /var/www/horde>
            Options +FollowSymLinks
            AllowOverride All
            order allow,deny
            allow from all
            AddType application/x-httpd-php .php
            php_value include_path ".:/usr/share/php"
            php_value open_basedir "none"
            php_value upload_tmp_dir "/var/www/horde/phptmp/"
</Directory>

<IfModule mod_rewrite.c>
#  <IfModule mod_ssl.c>
    <Location /webmail>

#      SSLOptions +StrictRequire
#      SSLRequireSSL
#      SSLRequire %{HTTP_HOST} eq "www.example.com"
#      ErrorDocument 403 https://www.example.com/horde

      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]

    </Location>
#  </IfModule>
</IfModule>

I have been asked if mod_rewrite is in effect on my server which I know it is.

Also if I put this code below to try and log the mod_rewrites apache fails to reload, even though the code is good according to multiple people.

Code:

RewriteLog /tmp/mod_rewrite.log
RewriteLogLevel 2

Any help would be greatly appreciated thank you.

sjswarts 13th January 2013 06:52

Help anyone? Still haven't figured this out. According to the guys over at Horde support its something to do with mod_rewrite...

But because my system is using ISPConfig they are quite stand-off-ish...

thias 5th February 2013 00:02

Hi Sjswarts,

I had the same troubles, though my ISPconfig based Server worked out of th ebox.
I have another ubuntu system running Horde 5 which had the same problem recently.
I had to put the following directives somewhere in my apache conf.

Yours is missing these specific directives:
<Directory /var/www/horde/>
AllowOverride Options Fileinfo
Order allow,deny
allow from all
</Directory>

And additionally I have in hordes base conguration Pretty URLs with mod_rewrite enabled.

I hope this points you in the proper direction and you will solve your problem.

Cheers
Matthias

sjswarts 6th April 2013 09:41

Well its been forever since I've tried to fix this issue. But still no luck.

So you are saying that even though you have a horde.conf in /etc/apache2/conf.d/ you still add:

Code:

<Directory /var/www/horde/>
AllowOverride Options Fileinfo
Order allow,deny
allow from all
</Directory>

to /etc/apache2/apache2.conf

Is that right?? Seems odd...

Regards,

sjswarts

sjswarts 6th April 2013 09:45

I tried that but I get an error 500 - when I attempt to visit http://webmail.swartsit.com

This is the error log:

Code:

tail -f /var/www/swartsit.com/log/error.log
Quote:

/var/www/horde/.htaccess: allow not allowed here
I don't know what that means...

sjswarts 7th June 2013 19:39

So... still nothing guys??


All times are GMT +2. The time now is 05:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.