HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Postfix + Fedora Core 5 64Bit - Problem (http://www.howtoforge.com/forums/showthread.php?t=5977)

GrBase 3rd August 2006 20:28

Postfix + Fedora Core 5 64Bit - Problem
 
I have install Fedora core 5 following the instructions of "The Perfect Setup - Fedora Core 5 (64-bit)" by Falko
I am running a 64bit AMD Athlon which I want to make it a web and mail server.
The web server is working ok!! but the mail server is not working properly.
When I am trying to send and receive e-mail from a WINxp system using outlook and an account on the Fedora server, it seems to working ok but no e-mails are sent or received. Outlook is connected to the server and finds no new messages. When I am trying to send an e-mail outlook says that the message is sent but the message doesn’t go to the recipient.
I am using Postfix and when I am trying telnet local host 25 I am getting ............
--------------------------------------------------
[root@ns ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 ns.nestor.org.gr ESMTP Postfix
ehlo localhost
250-ns.nestor.org.gr
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
[root@ns ~]#
--------------------------------------------------

I notice that at /home/<anyuser>/Maildir don't exist, there is only 'mail' folder

The /etc/postfix/main.cf file is as following
---------------------------------------------------------------------
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = ns.nestor.org.gr
mydomain = nestor.org.gr
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5
home_mailbox = Maildir/
mailbox_command =
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
-------------------------------------------------------------------------

It seems I am doing something wrong :mad:

falko 4th August 2006 13:28

What's in /var/log/maillog when you try to send or receive emails?

Are you using ISPConfig?

GrBase 5th August 2006 16:38

Dear Falco

After re-installing the system from the beginning it seems to work properly.
I have install the ISPConfig.
Following the steps of “The Perfect Setup - Fedora Core 5 (64-bit)” I notice that after finishing the steps of “Postfix with SMTP-AUTH and TLS”
in the /etc/postfix/main.cf file the line
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
was not created and I add the line manually.

Finally the web server is working and the mail server cause only one problem …..
I create a user named ‘info’
I send e-mail to ‘info’ using Outlook and then I check the info account using Outlook and no e-mail was received.

At /var/log/maillog I see the following:
======================================
Aug 5 17:11:09 ns postfix/smtpd[1996]: connect from unknown[195.251.5.206]
Aug 5 17:11:09 ns postfix/smtpd[1996]: 140ACA28114: client=unknown[195.251.5.206]
Aug 5 17:11:09 ns postfix/cleanup[2006]: 140ACA28114: message-id=<01a801c6b898$fdfe9ea0$cc05fbc3@graviton>
Aug 5 17:11:09 ns postfix/qmgr[558]: 140ACA28114: from=<kostoglou@nestor.org.gr>, size=1355, nrcpt=1 (queue active)
Aug 5 17:11:09 ns postfix/smtpd[1996]: disconnect from unknown[195.251.5.206]
Aug 5 17:11:09 ns postfix/local[2007]: 140ACA28114: to=<root@ns.nestor.org.gr>, orig_to=<info@nestor.org.gr>, relay=local, delay=0, status=sent (delivered to mailbox)
Aug 5 17:11:09 ns postfix/qmgr[558]: 140ACA28114: removed
Aug 5 17:11:13 ns dovecot: pop3-login: Login: user=<info>, method=PLAIN, rip=::ffff:195.251.5.206, lip=::ffff:195.251.5.3
Aug 5 17:11:13 ns dovecot: POP3(info): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
==================================

Note that:
ns.nestor.org.gr is the server name
195.251.5.206 is the ip address of my personal pc
graviton is my personal pc name

How I will fix this ?

In the ISPConfig, the option Spamfilter is unchecked.
How this filter works? Is it safe that I will not loose imprortant e-mails ?
Does it worth to try it?

Thanks in adnance
Antonis

falko 6th August 2006 16:23

Quote:

Originally Posted by GrBase
How I will fix this ?

What's in /etc/aliases?

Quote:

Originally Posted by GrBase
In the ISPConfig, the option Spamfilter is unchecked.
How this filter works? Is it safe that I will not loose imprortant e-mails ?

You can specify in ISPConfig what happens to spam. You can have it deleted or delivered (with a rewritten subject) so that you can do the filtering in your email client. No email is lost when you choose to have spam delivered.

GrBase 6th August 2006 20:59

Quote:

Originally Posted by falko
What's in /etc/aliases?

Dear Falco thank you for the info. I comment out the line
info: postmaster
in the /etv/aliases file and the info account is working ok! :)

Quote:

Originally Posted by falco
You can specify in ISPConfig what happens to spam. You can have it deleted or delivered (with a rewritten subject) so that you can do the filtering in your email client. No email is lost when you choose to have spam delivered.

Could you please help me about how I will specify in ISPConfig the settings for the spamfilter?

Thanks

falko 7th August 2006 13:41

Quote:

Originally Posted by GrBase
Could you please help me about how I will specify in ISPConfig the settings for the spamfilter?

Thanks

Have a look here: http://www.ispconfig.org/downloads/m..._src.htm#4_2_2 section 2.2.5.


All times are GMT +2. The time now is 09:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.