HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   phpmyadmin max upload size (http://www.howtoforge.com/forums/showthread.php?t=59727)

ttoine 29th November 2012 00:17

phpmyadmin max upload size
 
Hi,

I followed the howto "The perfect server - Ubuntu 12.04..." with ISPConfig 3. Great, thanks a lot! I am working on a testing server, I hope soon to be able to put my Wordpress Multisites websites from shared hosts to VPS hosts.

I only have a problem with phpmyadmin: I cannot import files bigger than 2M with http://libre-factory.org/phpmyadmin/ . As you can check on http://libre-factory.org/phpinfo.php , I set it to 32M.

After searching on the forum, I found stuff about something like that, but for ISPConfig 2. And when I try to edit the suggested file with nano, it is empty... So I guess I am missing something with the ISPConfig3 setup. But what ?

Toine

till 29th November 2012 07:46

Just edit the max upload file size in the file /etc/php5/apache2/php.ini and restart apache.

ttoine 29th November 2012 10:21

Till,

If I set upload_max_filesize to 32M, then in phpmysql it is 8M max...

till 29th November 2012 11:19

Then you might run your phpmyadmin on e.g. fastcgi or suphp and not mod_php. The php.ini for cgi, suphp and fastcgi is:

/etc/php5/cgi/php.ini

ttoine 29th November 2012 12:14

So, after checking both files and trials:
- /etc/php5/cgi/php.ini -> websites created with ISPConfig3, that's why phpinfo show this loaded file
- /etc/php5/apache2/php.ini -> ISPConfig3, Phpmyadmin, etc...

Right ?

till 29th November 2012 12:26

No, the php.ini depends on the php mode that you use for the different sites or software applications:

php cgi: /etc/php5/cgi/php.ini
php fcgi: /etc/php5/cgi/php.ini
suphp: /etc/php5/cgi/php.ini
mod_php: /etc/php5/apache2/php.ini

ttoine 29th November 2012 18:07

Till,

Thanks for your answers. I think ISP Config 3 is too complicated for me:
- editing apache, php or mysql config files cannot be done in ISPConfig, still need terminal
- ssh, ftp or webdav can not be created with the same directory, username, password in one time
- some stuff with "The perfect server..." don't fit my need for Wordpress or don't work the good way (file upload in Wordpress get a server error, etc...)

So I will look for something more easy to manage.

till 29th November 2012 18:28

Quote:

- editing apache, php or mysql config files cannot be done in ISPConfig, still need terminal
Normally you dont have to do that after initial setup of the server as you can do all required settings for the sites, databases etc. in ispconfig.

Quote:

- ssh, ftp or webdav can not be created with the same directory, username, password in one time
You can access the same directory with ssh and ftp users. Users were not created together as ispconfig offers a more fine grained control over users as it is required by larger hosting companies. If you run a small home server, then this might be too much for you indeed.

Quote:

- some stuff with "The perfect server..." don't fit my need for Wordpress or don't work the good way (file upload in Wordpress get a server error, etc...)
I run several wordpress sites on perfect setup debian servers, they work all out of the box.

ttoine 29th November 2012 18:43

What about Webdav ?

And with the Perfect server for Ubuntu 12.04, Wordpress don't work very well...

till 29th November 2012 20:16

Webdav in pavhe does not support to run under different users which is required for secures websites, so it is not possible to access the site files with webdav. For that reason, webdav is only implemented as file storage option and not to access websites.

Which problems do you had with wordpress. My guess is that you just used wrong site options as wordpress works out of the box on ubuntu systems that i installed for several clients. All php based cms system require the php mode php- fcgi and suexec has to be enabled, thats described in detail in the manual. With other php modes, you dont get write access to the site directory which is required by wordpress.


All times are GMT +2. The time now is 04:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.