HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPConfig 3 (restart/shutdown/power failure) (http://www.howtoforge.com/forums/showthread.php?t=59677)

onastvar 23rd November 2012 20:56

ISPConfig 3 (restart/shutdown/power failure)
 
Every time I restart/shutdown or in case of power failure my server, I have to do the following to get ISPConfig to work.

Code:

fuser -n tcp 80
I get: 80/tcp: 5738 5739 5740 5741 5742 5743

Code:

kill -9 5738
kill -9 5739
kill -9 5740
kill -9 5741
kill -9 5742
kill -9 5743

sudo /etc/init.d/nginx restart

after I do above steps my server works, however running processes are:

www-data 5739 0.0 0.2 91856 22240 ? S 13:37 0:00 nginx: worker process
www-data 5740 0.0 0.2 91856 21484 ? S 13:37 0:00 nginx: worker process
www-data 5741 0.0 0.2 91856 21484 ? S 13:37 0:00 nginx: worker process
www-data 5742 0.0 0.2 91856 22188 ? S 13:37 0:00 nginx: worker process
www-data 5743 0.0 0.2 91856 21400 ? S 13:37 0:00 nginx: cache manager proces
s

Anyone knows why is this happening after every restart or power failure?

Thank You!

falko 24th November 2012 12:13

Maybe it's a problem with nginx on Debian Squeeze? I haven't seen such problems on Debian Wheezy so far.


All times are GMT +2. The time now is 12:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.