HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Internal Server Error when trying to open ISPConfig Panel (http://www.howtoforge.com/forums/showthread.php?t=59609)

serdyuk 17th November 2012 12:04

Internal Server Error when trying to open ISPConfig Panel
 
Hello guys,

I have a problem after upgrading to ISPConfig 3.0.5-beta1. I'm getting Internal Server Error when trying to open ISPConfig panel now. All the websites function normally. Problem exists with ISPConfig Panel only.

It is on CentOS release 5.7 (Final)
error.log says:
Quote:

[Fri Nov 16 19:40:30 2012] [notice] mod_fcgid: call /var/www/ispconfig/index.php with wrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
.php-fcgi-starter: line 6: /usr/lib/cgi-bin/php: No such file or directory
.php-fcgi-starter: line 6: exec: /usr/lib/cgi-bin/php: cannot execute: No such file or directory
[Fri Nov 16 19:40:30 2012] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Fri Nov 16 19:40:30 2012] [error] [client 192.168.1.2] Premature end of script headers: index.php
[Fri Nov 16 19:40:36 2012] [notice] mod_fcgid: process /var/www/ispconfig/index.php(26132) exit(communication error), terminated by calling exit(), return code: 126
Seems like I need to change paths somewhere, but I do not know where to do that.
I would really appreciate it if you could direct me on what to do and where.

Thank you very much!

serdyuk 17th November 2012 20:37

Fixed by using information from here: http://www.howtoforge.com/forums/sho...52&postcount=9

In case someone else has the same problem - you need to edit
/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter

Change path "/usr/lib/cgi-bin/php" to "/usr/bin/php-cgi \"

It helped me and hope can help you as well.

Please feel free to provide corrections in case there is something wrong in what I have written here.

Regards.

pakogah 27th February 2013 09:10

thanks it works


All times are GMT +2. The time now is 01:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.