HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ownCloud ISPConfig 3 (.htaccess) (http://www.howtoforge.com/forums/showthread.php?t=59318)

sjswarts 30th October 2012 16:29

ownCloud ISPConfig 3 (.htaccess)
 
G'day guys,

I have Debian 6 (Squeeze) VPS with ISPConfig 3 installed. I'm looking at hosting some audio files for my Church seeing that I have 160GB of transfer per month and the files are about 150MB each (about 1.5 hours long).

Anyway I tried Subsonic (way too many options and clickable hiccups for old people or low IT literate people) tried a few other options aswell until I found ownCloud which looks sleek, clean and easy to use/administer.

My issues are these:

Firstly on a test virtual server (Debian) I can get it to work great, but it complains about .htaccess - which I can remedy but then I need to change the whole Apache config to
Code:

AllowOverride All
in
Quote:

/etc/apache2/sites-available/default
however is this the recommended way? security issues? administrator concerns?

Secondly on my test virtual server (Debian 6 and ISPConfig 3 = 192.168.1.201) I make a fake site (example.com) and set the DNS to point to this server then on another test virtual machine (WinXP = 192.168.1.205) I set my DNS Servers in the network config to point to 192.168.1.201 and type in the fake site = example.com and all things work.

Now I follow the same install procedure but instead of placing it in
Quote:

/var/www/owncloud
i place it in
Quote:

/var/www/example.com/web/owncloud
and run
Code:

chown -R web1:client0 owncloud
But it doesn't show up when I navigate to What am I missing? On my actual VPS I didn't ever make another .conf file for phpBB3 (Forum) or for my Wordpress (Blog) I just placed the folder via FTP and it worked.

I did check out the log for client0 and it showed this:

Quote:

[Tue Oct 30 23:00:09 2012] [emerg] [client 192.168.1.205] (13)Permission denied: mod_fcgid: can't lock process table in pid 6392
Any help would be appreciated. I don't mind to make a tutorial up if things work but word of warning I am a noob ;)

Cheers guys,
Regards,
Steven Swarts

sjswarts 30th October 2012 16:47

Ok so I changed the setting of the website (example.com) in the test virtual server (Debian ISPConfig 3) to ModPHP and it works as expected.

However my currently running website http://www.swartsit.com is running under Fast-CGI

NOOB ALERT: I don't know the differences at all

But I use these "addons" to my client0:

phpBB3 = Forum
WordPress = Blog

So is this the right direction or am I completely mistaken?

Cheers,
Steven Swarts

till 30th October 2012 16:50

fast-cgi is the correct php mode.Please ensure that the suexec checkbox is enabled in the website settings as well.

Please post the output of this command:

ls -la /var/www/example.com/web/

sjswarts 30th October 2012 17:00

Quote:

Originally Posted by till (Post 287544)
fast-cgi is the correct php mode.Please ensure that the suexec checkbox is enabled in the website settings as well.

Please post the output of this command:

ls -la /var/www/example.com/web/

Thanks Till, I thought as much found this: http://www.howtoforge.com/forums/arc...p/t-33167.html

suexec is enabled as well

Code:

drwx--x---  5 web1 client0 4096 Oct 30 23:32 .
drwxr-x--x  6 web1 client0 4096 Oct 30 22:47 ..
drwxr-xr-x  2 web1 client0 4096 Oct 30 22:47 error
-rwxr-xr--  1 web1 client0 7358 Oct 30 22:47 favicon.ico
-rwxr-xr--  1 web1 client0  26 Oct 30 22:47 .htaccess
-rw-r--r--  1 web1 client0  86 Oct 30 23:32 index.html
-rwxr-xr--  1 web1 client0 1861 Oct 30 22:47 index.html.bak
drwxr-xr-x 14 web1 client0 4096 Oct 30 23:43 owncloud
-rwxr-xr--  1 web1 client0  24 Oct 30 22:47 robots.txt
-rw-r--r--  1 web1 client0 6957 Oct 10 23:06 setup-owncloud.php
drwxr-xr-x  2 web1 client0 4096 Oct 30 22:47 stats


till 30th October 2012 17:17

Thats ok, please run this command and try to access the ownloud site again:

chown -R web1:client0 /var/www/php-fcgi-scripts/web1

Additionally, the owncloud setup script seems to be in the web directorym not the owncloud directory. What happens if you access this url:

http://example.com/setup-owncloud.php

sjswarts 30th October 2012 17:27

Quote:

Originally Posted by till (Post 287546)
Thats ok, please run this command and try to access the ownloud site again:

chown -R web1:client0 /var/www/php-fcgi-scripts/web1

Nothing changed...

Quote:

Originally Posted by till (Post 287546)
Additionally, the owncloud setup script seems to be in the web directorym not the owncloud directory. What happens if you access this url:

http://example.com/setup-owncloud.php

Yeah according to the ownCloud website there are two options to install either by this php script or by downloading the code and manually installing.

In ISPConfig under Sites I have the following:

CGI = Checked
SSI = unChecked
Ruby = unChecked
Python = unChecked
SuEXEC = Checked
Own Error-Documents = Checked
Auto-Subdomain = www.
SSL = unChecked
PHP = Fast-CGI
Active = Checked

Unfortunately neither work. But if I change to ModPHP it does.
Very strange and the logs just mention the same as I posted above.

sjswarts 30th October 2012 18:11

For some reason I decided to try it on my actual live VPS and changed the DNS of the Virtual Machine (Win XP) to point there. Setup DNS on my VPS as well and it works fine. Settings are identical I am running Fast-CGI with suexec and everything.

So strange, this test ISPConfig is more or less brand new. Something must be broken.

.htaccess is however not working still

I believe the server settings are at

Code:

AllowOveride None
Any ideas?

Cheers,
Steven Swarts

till 30th October 2012 18:38

The htaccess settings in ispconfig are "AllowOverride All" for all .htaccess files inside a website, so you can use any config options that are allowed for .htaccess files inside the /web/ directory of the site. All settings are defined by site, so the global override settings do not matter as they dont get applied to files in a website. Owncloud shall work out of the box, I've testet it some time ago and did not had to do any modications on a server installed as described in the perfect setup guide.

sjswarts 31st October 2012 06:13

Quote:

Originally Posted by till (Post 287552)
The htaccess settings in ispconfig are "AllowOverride All" for all .htaccess files inside a website, so you can use any config options that are allowed for .htaccess files inside the /web/ directory of the site. All settings are defined by site, so the global override settings do not matter as they dont get applied to files in a website. Owncloud shall work out of the box, I've testet it some time ago and did not had to do any modications on a server installed as described in the perfect setup guide.

Well I found that it installed fine via the script (assuming it would also by the download and extract method).

As for the .htaccess it doesn't take preference over the server. I set the settings in ownCloud and it DOES take effect (shown in /var/www/client/web/owncloud/.htaccess) but still uses server preferences listed in

Code:

/etc/php5/cgi/php.ini
which are for upload limits ...
Personally that works for me, but I could see that hosting providers would want to limit the upload to 5-25Mb. But in this case I wanted to have at least 150Mb upload.

till 31st October 2012 08:38

Quote:

As for the .htaccess it doesn't take preference over the server. I set the settings in ownCloud and it DOES take effect (shown in /var/www/client/web/owncloud/.htaccess) but still uses server preferences listed in
You mix up a few things here, the .htaccess works fine and overrides the settings in the global apache configuration on your server. A .htaccess file is a config file of the apache server and not a config file of the php binary, the php settings that you refer to like php_value or php_flag are settings for the apache module mod_php and not for the php-fcgi program. You can set values for php-fcgi in the php.ini field of the website, so its even easier then editing a .htaccess file manually, the syntax is the same that you find in the php.ini.


All times are GMT +2. The time now is 16:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.