HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   (mail for mail.example.com loops back to myself) (http://www.howtoforge.com/forums/showthread.php?t=59314)

magicalshashank31 30th October 2012 10:34

(mail for mail.example.com loops back to myself)
 
I am configuring E-mail server in centos 6 by following http://www.howtoforge.com/virtual-us...a-17-x86_64-p4.

All things are working, but when i try to send mail it says the error:
1.mail for mail.example.com loops back to myself. #when i try to send mail from my centos6
2.when i try to acces mails via squirrelmail login page ,but when i login through sales@example.com and password secret it says connection dropped by imap server The logs of the maillog file is given
Code:

Oct 30 20:24:34 localhost clamd[5285]: SelfCheck: Database status OK.
Oct 30 20:27:46 localhost imapd: Connection, ip=[::ffff:192.168.137.130]
Oct 30 20:27:46 localhost imapd: chdir example.com/sales/: No such file or directory
Oct 30 20:27:46 localhost imapd: sales@example.com: No such file or directory

# when i tery to open sales@example.com it says Connection dropped by imap server .

MY main.cf is:

Code:

postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mail_spool_directory = /var/spool/mail
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = localhost, localhost.localdomain, server.example.com
mydomain = example.com
myhostname = server.example.com
mynetworks = 127.0.0.0/8
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
receive_override_options = no_address_mappings
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
unknown_local_recipient_reject_code = 550
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_uid_maps = static:5000

when i try from system
#mailx sales@example.com
hiiii
ctrlD
nd check the logs it gives . (here sales@example.com is a virtual user but even the same problem comes up with system users also)
Code:

tail /var/log/maillog
Oct 30 20:04:45 localhost postfix/qmgr[9149]: D2B411A1347: from=<root@example.com>, size=863, nrcpt=1 (queue active)
Oct 30 20:04:45 localhost postfix/smtpd[9174]: disconnect from unknown[127.0.0.1]
Oct 30 20:04:45 localhost amavis[5323]: (05323-12) Passed CLEAN, <root@example.com> -> <sales@example.com>, Message-ID: <20121030143434.198B01A1348@server.example.com>, mail_id: wtEuHsHmOmVi, Hits: 0, size: 430, queued_as: D2B411A1347, 11797 ms
Oct 30 20:04:45 localhost postfix/smtp[9168]: 198B01A1348: to=<sales@example.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=12, delays=0.22/0.01/0/12, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=05323-12, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as D2B411A1347)
Oct 30 20:04:45 localhost postfix/qmgr[9149]: 198B01A1348: removed
Oct 30 20:04:45 localhost postfix/smtp[9155]: D2B411A1347: to=<sales@example.com>, relay=none, delay=0.07, delays=0.07/0/0/0, dsn=5.4.6, status=bounced (mail for mail.example.com loops back to myself)
Oct 30 20:04:45 localhost postfix/cleanup[9158]: F1FC41A1348: message-id=<20121030143445.F1FC41A1348@server.example.com>

please help !!

falko 1st November 2012 08:06

Please add mail.example.com to the mydestination line in /etc/postfix/main.cf and restart Postfix.


All times are GMT +2. The time now is 14:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.