HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Can't create sites after centos 6.3 upgrade (http://www.howtoforge.com/forums/showthread.php?t=59285)

inferno3031 28th October 2012 19:36

Can't create sites after centos 6.3 upgrade
 
Hello everyone,

as i wrote in the topic title i have an issue with my ispconfig 3 after centos 6.2 > 6.3 upgrade. The only thing that seems not to work is adding new sites and of course ftp users along with it. When i looked closely at what ispconfig is doing while adding a site i saw this in the base_dir, debug logs and ispconfig database entries :

/var/www/clients/client0/web27/web:/var/www/clients/clijavascript:changeTab(\'dns\',\'admin/server_config_edit.php\')ent0/web27/tmp:/var/www/site-domain.com/web:/srv/www/site-domain.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php

So obviously the problem is the additional js string in the directory name. I don't know how this string is getting there and i hoped you could help me. For the record i used firefox and chrome for it so i doubt it would be my browsers fault. Can anyone help me pls?

till 29th October 2012 08:52

Did you made a ispconfig update after you upgraded centos? If not, download the ispconfig tar.gz file, unpack it and run the update.php script which is in the install folder. Choose to reconfigure services when the updater asks you.

inferno3031 29th October 2012 09:00

If i remember it correctly i think i did a small ispconfig update back then. I did it through ispconfig_update.sh. Should i still run the the update.php with reconfiguring the services?

till 29th October 2012 09:03

Yes, please do the manual update again.

inferno3031 29th October 2012 09:31

Ok so i did the manual update of the ispconfig with reconfiguring services. Unfortunately i still get the same result :

(from the ispconfig syslog)
2012-10-29 08:20 xxx.com Debug Creating symlink: ln -s /var/log/ispconfig/httpd/domain.com /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web29/log

Do you have any other ideas? Maybe theres something wrong with my ispconfig files? Or my php? This js added in fields is so werid.

till 29th October 2012 10:21

Quote:

Maybe theres something wrong with my ispconfig files?
This was my guess, but the update shuld have replaced all fies. Or do you use a custom ispconfig theme which has not been replaced by the update?

What happens when you set the correct open_basedir path in the open basedir field of the website and click on save, is the path then correct or did the javascript code added again?

inferno3031 29th October 2012 10:54

No i use a standard theme. I even switched language from polish to english back but it didn't help either. When i remove the js from the basedir in site options it doesn't appear there again (like the websites i created before the update have their basedirs all ok and working). But when i change it it doesn't create the new directory Like when i change this :

/var/www/clients/clijavascript:changeTab(\'dns\',\'admin/server_config_edit.php\')ent0/web33/web:/var/www/clients/clijavascript:changeTab(\'dns\',\'admin/server_config_edit.php\')ent0/web33/tmp:/var/www/avc.pl/web:/srv/www/avc.pl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php

to this

/var/www/clients/client0/web33/web:/var/www/clients/client0/web33/tmp:/var/www/avc.pl/web:/srv/www/avc.pl/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php

I have no web33 in my client0 folder. I also tried creating a site from client account also without any improvement.

till 29th October 2012 11:00

I guess this is a new website? In this case, please delete the site and recreate it after you enabled debugging and post the messages that you get. See end of this post for details on debug mode:

http://www.howtoforge.com/forums/showthread.php?t=58408

inferno3031 29th October 2012 11:09

Thanks for your help so far. Is this what you wanted? :

Code:

2012-10-29 09:57 my-host.pl Debug Calling function 'restartHttpd' from module 'web_module'. 
2012-10-29 09:57 my-host.pl Debug Processed datalog_id 1348 
2012-10-29 09:57 my-host.pl Debug Calling function 'restartHttpd' from module 'web_module'. 
2012-10-29 09:57 my-host.pl Warning Apache did not restart after the configuration change for website test-domain.pl Reverting the configuration. Saved non-working config as /etc/httpd/conf/sites-available/test-domain.pl.vhost.err Delete 
2012-10-29 09:57 my-host.pl Debug Apache online status after restart is: 
2012-10-29 09:57 my-host.pl Debug Calling function 'restartHttpd' from module 'web_module'. 
2012-10-29 09:57 my-host.pl Debug Apache status is: 1 
2012-10-29 09:57 my-host.pl Debug Creating symlink: /etc/httpd/conf/sites-enabled/100-test-domain.pl.vhost->/etc/httpd/conf/sites-available/test-domain.pl.vhost 
2012-10-29 09:57 my-host.pl Debug Writing the vhost file: /etc/httpd/conf/sites-available/test-domain.pl.vhost 
2012-10-29 09:57 my-host.pl Debug Creating fastcgi starter script: /var/www/php-fcgi-scripts/web35/.php-fcgi-starter 
2012-10-29 09:57 my-host.pl Debug Creating fastcgi starter script directory: /var/www/php-fcgi-scripts/web35

2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/log/error.log 
2012-10-29 09:57 my-host.pl Debug exec: chown -R web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/web 
2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/tmp 
2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/ssl 
2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/log 
2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/cgi-bin 
2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35 
2012-10-29 09:57 my-host.pl Debug exec: usermod --groups sshusers web35 
2012-10-29 09:57 my-host.pl Debug exec: chmod 755 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/log 
2012-10-29 09:57 my-host.pl Debug exec: chmod 777 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/tmp 
2012-10-29 09:57 my-host.pl Debug exec: chmod 710 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/web 
2012-10-29 09:57 my-host.pl Debug exec: chmod 751 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/* 
2012-10-29 09:57 my-host.pl Debug exec: chmod 751 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35 
2012-10-29 09:57 my-host.pl Debug exec: chown web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/web 
2012-10-29 09:57 my-host.pl Debug exec: chown -R web35:client0 /var/www/clients/clijavascript:changeTab('dns','admin/server_config_edit.php')ent0/web35/web
2012-10-29 09:57 my-host.pl Debug Adding the user: web35 
2012-10-29 09:57 my-host.pl Debug Calling function 'insert' from plugin 'apache2_plugin' raised by event 'web_domain_insert'. 
2012-10-29 09:57 my-host.pl Debug Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_insert'. 
2012-10-29 09:57 my-host.pl Debug Processed datalog_id 1347


till 29th October 2012 11:17

Thanks for posting the debug output.

Which exact ispconfig version do you use, 3.0.4.6?


All times are GMT +2. The time now is 16:05.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.