HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   multiple domains - postfix/dovecot/mysql (http://www.howtoforge.com/forums/showthread.php?t=59278)

blinky 27th October 2012 20:38

multiple domains - postfix/dovecot/mysql
 
Hidee ho... again...

Some of you are likely going to think I'm thick as a plank I've been here so often in the past couple months but I keep coming back to the well because it's got water in it.

I have been able to configure postfix/dovecot/mysql with virtual users/domains (and postfixadmin) on a Ubuntu 12.04 system. I was having some problems connecting to the SMTP server off-site but determined the most likely cause was that the *other* ISP was blocking port 25 so I thought I'd use port 587 instead. As a result, I added the following to the postfix master.cf file:

Code:

submission inet n - - - - smtpd
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_sasl_type=dovecot
  -o smtpd_sasl_path=private/auth
  -o smtpd_sasl_security_options=noanonymous
  -o smtpd_sasl_local_domain=$myhostname
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject

The above information I found via Google.

Now, for my primary domain (which I'll call mail.example.com) everything works fine... mail gets processed by accessing the mysql virtual database without problem. But for the secondary domain (which I'll call mail.otherexample.com) the mail gets bounced rejecting it as anonymous.

Interestingly, if I connect to the same machine from an ISP that does not block port 25 and I configure the client to use port 25 both domains get processed fine.

What I need to figure out is how to configure the server to handle ALL domains and users on port 587.

I'm sure there's a simple setting I've overlooked. Sheesh, talk about a pile of configuration files to get this puppy up and running!

I thank you all in adance for your time and patience.


All times are GMT +2. The time now is 18:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.