HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Mail login displays instead of web page (http://www.howtoforge.com/forums/showthread.php?t=59260)

amerkfan 26th October 2012 15:33

Mail login displays instead of web page
 
Good Morning... I have searched the forum for an answer, but being a newbie, I must be missing something. I am setting up a server to host my personal page and act as a picture server for my many family members. Since May, I have set up and rebuilt this server several times using the same settings and steps as I 'play' around with the settings. In the past I haven't had the current problem defined below.

I have set up an ubuntu (12.04) server with ispconfig3 using the perfect server instructions using howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3.

During the install I received no error messages. I created a new client tomsmess.com using my domain registrars dns ns1.ipage.com & ns2.ipage.com

The problem I have is that when I try to access tomsmess.com, it displays the squirrelmail log in and not the default ispconfig3 web page.

Thanks in advance for your help

falko 27th October 2012 10:37

You must use https://tomsmess.com:8080/

amerkfan 27th October 2012 18:57

My apologies for not being clear. I can access the ispconf control panel, I cannot access the web page for the client site. I expect to see the default congratulations this is your web page screen, but I get squirrelmail log in instead. This is a clean install, and I have only one client, me. I am accessing the webpage and control panel from outside the local network that hosts the server. I found one similar issue in the forums, but the solution was not the one I need.

falko 28th October 2012 11:54

Do you use * or a specific IP address for the website in ISPConfig? If you use *, please try a specific IP.

amerkfan 28th October 2012 17:59

My ispconfig set up for tomsmess.com looks like this:
mail A record 173.85.xxx.xxx
tomsmess.com A record 173.85.xxx.xxx
www A record 173.85.xxx.xxx
tomsmess.com MX record mail.tomsmess.com
tomsmess.com NS record ns1.ipage.com
tomsmess.com NS record ns2.ipage.com

I have tried different combinations of using the local address 192.168.0.xx using the server address and still no success. the 173.85.xxx.xxx address is the wan address given by my modem.

**Update**
I did a fresh install yesterday and still get the same results. I noticed that I had actually had posted the same issue in March 2012 (http://www.howtoforge.com/forums/showthread.php?t=56744) and you asked for the output of the document roots ls -la. Here it is:
root@server1:/var/www/tomsmess.com/web# ls -la
total 36
drwx--x--- 4 web1 client1 4096 Oct 28 22:01 .
drwxr-x--x 6 web1 client1 4096 Oct 28 22:01 ..
drwxr-xr-x 2 web1 client1 4096 Oct 28 22:01 error
-rwxr-xr-- 1 web1 client1 7358 Oct 28 22:01 favicon.ico
-rwxr-xr-- 1 web1 client1 26 Oct 28 22:01 .htaccess
-rwxr-xr-- 1 web1 client1 1861 Oct 28 22:01 index.html
-rwxr-xr-- 1 web1 client1 24 Oct 28 22:01 robots.txt
drwxr-xr-x 2 web1 client1 4096 Oct 28 22:01 stats

Hope this helps



Thanks

falko 29th October 2012 23:02

I'm not talking about DNS, I mean the website settings (the IPv4 drop-down).

amerkfan 30th October 2012 00:57

sorry, my misunderstanding. I use the * and tried the specific ip that did the trick. Thanks again falko for the help. This forum and the How To's are a huge help to us who are looking for guidance while learning Linux


All times are GMT +2. The time now is 11:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.