HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   DNS server sometimes stops working? (http://www.howtoforge.com/forums/showthread.php?t=59203)

crebilis 23rd October 2012 01:21

DNS server sometimes stops working?
 
Hi Everyone,


Recently I took up the plan to make myself a website development server at home. I bought a netbook to be the server and installed ispconfig 3 on it. I created some websites on it and everything went well so far. At that time I was simply using the hosts file on my computer to reach the server. However this was rather impractical if I wanted to change computers to work on.

Therefor I decided to use the DNS server capabilities of ISPConfig. All this is very new to me, so I struggled a little bit to get everything working. I set up my router to recognise my server as DNS server as well. In the end I thought I managed to get everything right and I could reach all my dev websites without using the hosts files.

The problem I'm having now is that sometimes the whole system decides it wants to stop working for no apparent reason. I don't think I'm doing anything to trigger this. After a while it all starts working again. I can still reach the server by directly using the IP address, however the domain names are unreachable. "Server not found".

I have 2 urls set up (actually more, but the effect is the same on all and for the example these 2 urls should be enough I think). The ip of the server is 192.168.1.50

calvin.dev: This is more a general url to reach the server. There is no website configured behind this url. Just the standard url to reach the control panel, phpmyadmin, nameservers, ...
dev-cms.dev: This is the website I'm developing.

doing an nslookup of dev-cms.dev. I get the following output

Code:

C:\>nslookup dev-cms.dev
*** Can't find server name for address 192.168.1.50: Non-existent domain
Server:  ns.coditel.net
Address:  212.76.224.172

*** ns.coditel.net can't find dev-cms.dev: Non-existent domain

ns.coditel.net is my isp's dns server.

My ipconfig /all is

Code:

C:\>ipconfig /all

Windows IP-configuration

        Host-name  . . . . . . . . . . . .: pudding
        Primary DNS-suffix. . . . .:
        Node type: . . . . . . . . . .: unknown
        IP-routing enabled. . . . .: no
        WINS-proxy enabled. . . . . : no
        DNS-suffix search list. . . . : coditel.net

Ethernet-adapter LAN-connection 3:

        Connection specific. DNS-suffix: coditel.net
        Description. . . . . . . . . . .:
          Atheros AR8151 PCI-E Gigabit Ethernet Controller
        Physical adress. . . . . . . . . . . : 00-25-22-EB-B8-8B
        DHCP enabled. . . . . . . . . : yes
        Autoconfiguration enabled. : yes
        IP-adres. . . . . . . . . . . . . : 192.168.1.100
        Subnetmask. . . . . . . . . . . : 255.255.255.0
        Defaultgateway. . . . . . . . . : 192.168.1.1
        DHCP-server . . . . . . . . . . . : 192.168.1.1
        DNS-servers . . . . . . . . . . . : 192.168.1.50
                                            212.76.224.172
                                            82.216.111.122
        Lease obtained. . . . . . . . . : dinsdag 23 oktober 2012 0:46:12
        Lease verlopen . . . . . . . . .  : woensdag 24 oktober 2012 0:46:12

It was originally in Dutch. I tried to translate it. If something is unclear: please ask :).

Now to the DNS configuration itself. Please bear in mind that I'm new to all this and if I'm doing something retarder, please tell me. I'd be very happy to learn more about this subject.

I created a zone for each url I'm using. In this example, there are 2 DNS zones.

Code:

        calvin.dev        calvin.dev.        ns1.calvin.dev.        myname.gmail.com.       
        calvin.dev        dev-cms.dev.        ns1.calvin.dev.        myname.gmail.com.

Below is the configuration of the calvin.dev DNS zone
Code:

        A        calvin.dev.        192.168.1.50        0       
        A        mail        192.168.1.50        0       
        A        ns1        192.168.1.50        0       
        A        ns2        192.168.1.50        0       
        A        www        192.168.1.50        0       
        CNAME        pop3        mail.calvin.dev        0       
        MX        calvin.dev.        mail.calvin.dev.        10       
        NS        calvin.dev.        ns2.calvin.dev.        0       
        NS        calvin.dev.        ns1.calvin.dev.        0

And the DNS REcords of the dev-cms.dev zone.

Code:

        A        dev-cms.dev.        192.168.1.50        0       
        A        mail        192.168.1.50        0       
        A        www        192.168.1.50        0       
        MX        dev-cms.dev.        mail.dev-cms.dev.        10       
        NS        dev-cms.dev.        ns1.calvin.dev.        0

The nameserver for both zones is set to ns1.calvin.dev.

Does anyone have an idea what I'm doing wrong? It's not that the server itself is unreachable, as I can reach the server by only using the IP and thus bypassing the DNS stuff altogether. If anything is unclear, please ask :)


All times are GMT +2. The time now is 02:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.