HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   Poor performance on RoundCube using ISPConfig 3 (http://www.howtoforge.com/forums/showthread.php?t=59134)

todx 17th October 2012 15:01

[Solved] Poor performance on RoundCube using ISPConfig 3
 
I've been using ISPConfig 3 for a year or so. I've got a bunch of email accounts setup, each one has 5000+ emails in it. Whenever I go to RoundCube and click on Inbox it can take up to 2-3 seconds for the list of emails to load (locally not over the internet). This server is running on high-end components. Also not on SCSI but SSD - so disk and internet load shouldn't be a problem.

Now my question. Can this be result of poor server configuration? Or is there a problem with RoundCube? What should I do? Am I using the wrong email client?

till 17th October 2012 15:23

This can be caused by many different things, the default configuration of the perfects etup is very fast, but there might be changes in your server configuration that slow the system down or high load etc. So to find the bottleneck, you have to check services step by step.

As a first step, i would install another webmail client beside oundcube e.g. squirrelmail. Squirremail is quite fast, so if you dont get the same delay in squirrelmail that you get in roundcube, you have narrowed down the issue to roundcube. If you experience the same delays, then it might be related to the imap server configuration or harddisk performance / load of the server.

todx 17th October 2012 16:09

How can I check disk load of my server? What could be wrong with IMAP server (example for this case)?

till 17th October 2012 16:16

You installed squirrelmail and it reacts fast?

The other options are a wide field as config files for sevices contain hindreds of options, so please check the webmail client first.

You can see the server load with top or uptime command, If it is high (permamently > 10) then it can be related to your problem and in this case it might make sense to install io load monitoring software.

todx 17th October 2012 18:09

Well basically what I did is, like you said it could be the mail client, instead of installing squirrelmail client I googled a bit for RoundCube performance and found this:
http://trac.roundcube.net/wiki/Howto_Performance
from here, I checked a few settings, changed them properly and now my list of mails loads very quickly.

What I changed was:
'imap_cache' => 'db' # how/where and if to cache imap
'messages_cache' => true # caches the mesages into mysql which I found out its acctually faster than reading directly from mail directory
'imap_auth_type' => 'LOGIN' # which is my imap auth type, this setting skips RoundCubes one step towards authentication
'smtp_auth_type' => 'LOGIN' # so does this one

So yeah, basically this worked for me. Thanks Till.

By the way, I checked my server load and it was around 1.0 which is why I focused on the mail client.

Drakon 24th January 2013 12:01

Thanks
 
Thanks for your comments! Works for me too!

I've changed the same:
Code:

$rcmail_config['imap_cache'] = 'db';
$rcmail_config['messages_cache'] = true;

and the performance has improved when opening folders with thousand of e-mails (with Roundcube 0.8.4 + Postfix + MySQL + Courier IMAP).

Thanks! :)


All times are GMT +2. The time now is 17:25.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.