HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Custom login issues (http://www.howtoforge.com/forums/showthread.php?t=59125)

arspoetica 16th October 2012 22:08

Custom login issues
 
So I clicked the box for custom logins and changed the login name to 'name.place', but it changed my email address as well... It was name@domain.com and now it is name.place@mail.domain.com

I looked around at some posts on here that seemed to deal with similar issues but they all seem to be over my head. I tried one that mentioned changing the userdb (which seemed to have already been changed) in dovecot.conf and the user_query line in dovecot-sql.conf, afterwhich I got a replication error. So obviously I read something wrong and screwed that up, but it is easily fixable.

Honestly (if you can't tell already) I don't know anything about dovecot and have no clue if what I had read was the right thing or not.

Ideally I would be able to stick to the user.place scheme as the login, but I am starting to get a headache from messing with this :confused:

falko 17th October 2012 15:23

Are you referring to ISPConfig, or where did you change your username?

arspoetica 17th October 2012 17:30

Oh yeah, sorry, that would probably help wouldn't it.. The custom login option in ISP Config under system / interface config / mail

And I installed using the multi-server walkthrough in the 3.0.4.1 manual (although I have updated to the newest version since then)

Also, I can't receive email unless it is sent to the name.place@mail.domain.com address... if mail is sent to the other the server rejects it immediately, bypassing the catch-all I setup

Edit: I changed the username in email / email mailbox / login. So the email addy field says name@domain.com and the login field says name.place

till 17th October 2012 17:50

There are some issues with that function in the current 3.0.4.6 release, you might have to change the querys in the dovecot-sql.conf file to the ones used in ispconfig 3.0.5

Code:

password_query = SELECT password FROM mail_user WHERE login = '%u' AND disable%Ls = 'n'

user_query = SELECT email as user, maildir as home, CONCAT('maildir:', maildir, '/Maildir') as mail, uid, gid, CONCAT('*:storage=', quota, 'B') AS quota_rule, CONCAT(maildir, '/.sieve') as sieve FROM mail_user WHERE (login = '%u' OR email = '%u') AND disable%Ls = 'n'


arspoetica 17th October 2012 18:24

Wow, so I actually had seen this in another recent post that you responded to, but I apparently missed the ( )'s. So I assume that that is why I couldn't get it to work. Unfortunately I somehow managed to screw something else up in the minor tweaks that I made to the dovecot.conf and dovecot-sql.conf files or something else I messed up because I get this when I try to run /usr/local/ispconfig/server/server.sh

Quote:

17.10.2012-16:17 - ERROR - Replication failed. Error: (mail_user) in MySQL server: (localhost) Unknown column 'autoresponder_subject' in 'field list' # SQL: REPLACE INTO mail_user (`mailuser_id`,`sys_userid`,`sys_groupid`,`sys_per m_user`,`sys_perm_group`,`sys_perm_other`,`server_ id`,`email`,`login`,`password`,`name`,`uid`,`gid`, `maildir`,`quota`,`cc`,`homedir`,`autoresponder`,` autoresponder_start_date`,`autoresponder_end_date` ,`autoresponder_subject`,`autoresponder_text`,`mov e_junk`,`custom_mailfilter`,`postfix`,`access`,`di sableimap`,`disablepop3`,`disabledeliver`,`disable smtp`,`disablesieve`,`disablelda`,`disabledoveadm` ) VALUES ('1','1','2','riud','riud','','3','user@domain.com ','user,'$2$2u6fj6jR$FHud1CtJl.4QxLsuSAZDI0','user name','5000','5000','/var/vmail/domain/user','0','','/var/vmail','n','0000-00-00 00:00:00','0000-00-00 00:00:00','Out of office reply','','n','','y','n','n','y','n','n','n','n',' n')
17.10.2012-16:17 - ERROR - Error in Replication, changes were not processed.

arspoetica 17th October 2012 19:48

So looking through the forums and finding info about this error as it pertains to other problems is confusing me.. I don't really see how I messed things up so badly and I can't figure out for the life of me how to fix it. Did me messing up the dovecot-sql info screw up the table or did I change something else... :(

edit: Ok, so this is caused by me updating to the 3.0.5 alpha on a multi-server setup from what I can gather, and the best course of action is to add those unknown columns to the mail servers mysql mail_user table. Is that right? If so then how do I know what the correct table fields are?

edit my edit: YAY! SOLVED, so Till's response to someone else helped me
Quote:

Originally Posted by till (Post 268351)
Here the alter table statement from svn trunk:

Code:

ALTER TABLE  `mail_user` ADD  `autoresponder_subject` VARCHAR(255) NOT NULL DEFAULT 'Out of office reply' AFTER  `autoresponder_end_date`;

and then I had the same problem with disabledoveadm but found it in the servers mysql table (had to pull out one of my books cus I don't really know sql... at all)

So THANK YOU Till and Falko! Love you guys!


All times are GMT +2. The time now is 22:24.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.