HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   ISPConfig single server - not creating mysql databases (http://www.howtoforge.com/forums/showthread.php?t=59052)

malcolm_itdc 11th October 2012 19:38

ISPConfig single server - not creating mysql databases
 
I am new to ISPConfig but followed the tutorial (http://www.howtoforge.com/perfect-se...ispconfig-3-p6) to install version 3 of it and it and worked fine.

Set nice and simple mysql passwords with no special characters etc.

Created first client in the admin page fine, created site and assigned to the client no problem.

Tried to create a database for a client, seemed to work however no database was created.

The record exists in the dbispconfig database table web_database, but its just not there.

I can log in the database as root from the command prompt no problem but neither the client user or database are being created as I would have expected.

I have read a few posts regarding problems with hostnames / ip addresses or permissions which may be causing the issue but cant find a definitive post stating the solution for me to try.

I am on Centos 6.3 and installed everything according to the tutorial. My other issue is I cant even find an error anywhere to say it has hit any problems at all. I have looked in /var/log, /var/log/ispconfig, /var/log/ispconfig/http, and the mysql.log as well and the only thing i can see is in the access log saying that it saw me edit the database in the web page exiting with a 200 http code.

I must be missing something huge somewhere to even find an error message of some sort.... any ideas would be appreciated !!!

till 12th October 2012 10:19

Ensure that the mysql root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.con is correct and you might want to take a look here for debug instructions: http://www.howtoforge.com/forums/showthread.php?t=58408

malcolm_itdc 12th October 2012 10:42

Hi,

Thanks that helped a lot. The root password was set right. Turned out to be that cron wasnt running in the first place as when I run the job manually it created the databases I expected. Guess it just wasnt part of the install or is expected to be running anyway.

Plus now its good to know that tasks are run through that process in ispconfig which I didnt know before.

Thanks for your help !!

malcolm_itdc 12th October 2012 14:05

1 more question.... if I want to change the mysql root password (as i set it simple till i proved things), do i just need to edit this file :/usr/local/ispconfig/server/lib/mysql_clientdb.conf or are there other places as well??

till 12th October 2012 14:17

Thats the only place for the mysql root password.

malcolm_itdc 12th October 2012 14:43

cool! works fine. thanks


All times are GMT +2. The time now is 16:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.