HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   too many apache processes (http://www.howtoforge.com/forums/showthread.php?t=59022)

Jorem 9th October 2012 13:27

too many apache processes
 
I have a problem on 2 new low load (only 1 testsite per server) Ubuntu 12.04 servers (Perfect Server Setup). After a few days I get a max clients error and after that Apache crashes.

My current settings:
<IfModule mpm_prefork_module>
StartServers 3
MinSpareServers 3
MaxSpareServers 10
MaxClients 150
MaxRequestsPerChild 3000
</IfModule>

When I have higher settings here Apache crashes after a day.

The rest of the system is fully responsive. After the crash I checked the running processes and I see a lot of "/usr/sbin/apache2 -k start" lines.

It looks like the processes are not closed/terminated and endless processes are created.

Can that be the cause for the Apache crash? What can I do about it?

till 9th October 2012 13:37

This can be related to a bug in vlogger that occurs only on Ubuntu 12.04. Update ISPConfig to version 3.0.4.6 to fix that.

Jorem 9th October 2012 14:05

I have the latest version on the server. Can I change vlogger by hand?

till 9th October 2012 14:27

If you have the latest version and have choosen to reconfigure services on update, then vlogger is already changed. Please post the file /etc/apache2/sites-enabled/000-ispconfig.conf so that I can check if the config has been changed correctly.

Jorem 9th October 2012 14:50

this is my config:

LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" -d \"/etc/vlogger-dbi.conf\" /var/log/ispconfig/httpd" combined_ispconfig

<Directory /var/www/clients>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

# Do not allow access to the root file system of the server for security reasons
<Directory />
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<Directory /var/www/conf>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

# Except of the following directories that contain website scripts
<Directory /usr/share/phpmyadmin>
Order allow,deny
Allow from all
</Directory>

<Directory /usr/share/phpMyAdmin>
Order allow,deny
Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
Order allow,deny
Allow from all
</Directory>

# allow path to awstats and alias for awstats icons
<Directory /usr/share/awstats>
Order allow,deny
Allow from all
</Directory>

Alias /awstats-icon "/usr/share/awstats/icon"

*Removed the last 2 lines with the ip.

till 9th October 2012 14:55

Ok, seems as if you have not reconfigured services during update which caused that your configuration files were not be fixed. Chaneg the custm log line to:

Code:

CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" /var/log/ispconfig/httpd" combined_ispconfig

and restart apache.

Jorem 9th October 2012 21:27

I checked another server of a friend of mine who updated from 5 to 6 also, and on his server the line was changed after the update. I must have done something wrong during update. Changed the files by hand now like you advised.

Thanks for your help Till.


All times are GMT +2. The time now is 12:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.