HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   CentOS 6 and Dovecot 2 (http://www.howtoforge.com/forums/showthread.php?t=58937)

m.naumann 2nd October 2012 18:49

CentOS 6 and Dovecot 2
 
Hi,

I'd like to try using ISPConfig (3) on CentOS 6 with Dovecot 2. As far as I know this is not yet supported (is this still correct?), so for now it would be nice to just have a test installation based on it, if that's possible. I do know that ISPConfig 3 works with Dovecot 2 on Debian 6, so I assume it is possible to make ISPConfig recognize and configure Dovecot 2 on CentOS 6, too.

However, last time I tried it would not do it automatically, so I'm wondernig whether this is now a supported features or whether it's possible to force it, overriding defaults.

Thanks in advance.

falko 3rd October 2012 11:47

This is now supported. Take a look here:

http://www.howtoforge.com/perfect-se...ot-ispconfig-3
http://www.howtoforge.com/perfect-se...ot-ispconfig-3

m.naumann 3rd October 2012 16:31

That's great! I'm really looking forward to having Dovecot 2 working on this CentOS system with the latest ISPConfig 3.

m.naumann 4th October 2012 18:26

Hmm, I'm not sure this would really work now, or maybe I'm doing something wrong - please help!

On a CentOS 6.3 system I had previously setup ISPConfig on, I just removed all dovecot packages, ensured I had all CentOS repositories installed which are listed in

http://www.howtoforge.com/perfect-se...ot-ispconfig-3

(that's with the exception of the DAG repository, but this shouldn't matter),
then installed the dovecot packages listed in the how-to. I end up with dovecot configuration in /etc/dovecot/ with the main dovecot configuration file located at /etc/dovecot/dovecot.conf.

Then I ran install/update.php from the ISPConfig-3.0.4.6 tar.gz. This script now added /etc/dovecot.conf and /etc/dovecot-sql.conf, so two dovecot configuration files which use the Dovcecot 1.x configuration file layout, storing the configuration directly in /etc. Now I grep all the Dovecot configuration files for something ISPConfig related:

Code:

[root@ispconfig ~]# grep -ir ispconfig /etc/dovecot*
/etc/dovecot-sql.conf:connect = host=localhost dbname=dbispconfig user=ispconfig password=[redacted]
/etc/dovecot-sql.conf~:connect = host=localhost dbname=dbispconfig user=ispconfig password=[redacted]
[root@ispconfig ~]#

So apparently the ISPConfig 3.0.4.6 update script is assuming that I have dovecot 1.x installed (but I don't, I have 2.x). Should I try tp uninstall, then reinstall ISPConfig? Is there anything else I'm missing / doing wrong?

It may be worth pointing out that I'm installing in an OpenVZ container and that the updater script prints this on screen:
Code:

Operating System: Redhat or compatible, unknown version.
This system is:
Code:

[root@ispconfig ~]# cat /etc/redhat-release
CentOS release 6.3 (Final)
[root@ispconfig ~]#

Thanks in advance.

m.naumann 10th October 2012 16:50

I would very much appreciate some feedback on this one...

m.naumann 17th October 2012 15:47

Third and last attempt: bump

till 17th October 2012 16:19

Replace the files /etc/dovecot/dovecot.conf and /etc/dovecot/dovecot-sql.conf with symlinks to /etc/dovecot.conf and /etc/dovecot-sql.conf if the paths on your server do not match with the config file paths.


All times are GMT +2. The time now is 09:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.