HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while (http://www.howtoforge.com/forums/showthread.php?t=58886)

localseo 27th September 2012 14:20

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while
 
Hello,

Just finished installling through howto for :The Perfect Server - CentOS 6.3 x86_64 (Apache2, Dovecot, ISPConfig 3)

Everything seemed to be running fine until I setup a domain with some traffic and it lasted for about 5 minutes.

I now just get

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

When restarting apache I get

Quote:

Iniciando httpd: [Thu Sep 27 16:14:44 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
And apache error log shows this:

Quote:

[Thu Sep 27 16:15:01 2012] [notice] caught SIGTERM, shutting down
[Thu Sep 27 16:15:01 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Sep 27 16:15:01 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Sep 27 16:15:01 2012] [notice] Digest: generating secret for digest authentication ...
[Thu Sep 27 16:15:01 2012] [notice] Digest: done
[Thu Sep 27 16:15:01 2012] [error] python_init: Python version mismatch, expected '2.6.5', found '2.6.6'.
[Thu Sep 27 16:15:01 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Thu Sep 27 16:15:01 2012] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
[Thu Sep 27 16:15:01 2012] [notice] mod_python: Creating 4 session mutexes based on 10 max processes and 0 max threads.
[Thu Sep 27 16:15:01 2012] [notice] mod_python: using mutex_directory /tmp
[Thu Sep 27 16:15:01 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Sep 27 16:15:01 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.7 PHP/5.3.3 mod_python/3.3.1 Python/2.6.6 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
Any ideas how to fix?

Thank you
Adam

till 27th September 2012 14:31

Please post the error message from the error.log of the website.

localseo 27th September 2012 14:39

Sorry hadnt checked there, lots of Fiel does not exist and this

Quote:

[Thu Sep 27 16:24:42 2012] [error] [client 41.204.205.132] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Thu Sep 27 16:26:07 2012] [warn] [client 5.9.20.93] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 16:26:07 2012] [error] [client 5.9.20.93] Premature end of script headers: submit.php
Thanks

localseo 27th September 2012 15:25

Sorry didnt look there.


Quote:

[Thu Sep 27 16:24:42 2012] [error] [client 41.204.205.132] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Thu Sep 27 16:26:07 2012] [warn] [client 5.9.20.93] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 16:26:07 2012] [error] [client 5.9.20.93] Premature end of script headers: submit.php
Thanks

localseo 27th September 2012 21:01

Hi dont know why but my reply doesnt seem to be going back.

Trying again

This is the strangest thing I see in the domain error log

Thanks

Quote:

[Thu Sep 27 22:09:02 2012] [warn] [client 5.9.1.221] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 22:09:02 2012] [error] [client 5.9.1.221] Premature end of script headers: submit.php
[Thu Sep 27 22:09:13 2012] [warn] [client 5.9.1.221] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 22:09:13 2012] [error] [client 5.9.1.221] Premature end of script headers: submit.php

falko 28th September 2012 09:00

Quote:

[Thu Sep 27 22:09:13 2012] [warn] [client 5.9.1.221] mod_fcgid: read data timeout in 360 seconds
It seems as if your script is taking too long to execute.

localseo 1st October 2012 07:30

Thanks,

Will try to change conf too

<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
IdleTimeout 300
BusyTimeout 300
ProcessLifeTime 7200
IPCConnectTimeout 300
IPCCommTimeout 7200
</IfModule>

See if it works

Quote:

Originally Posted by falko (Post 286057)
It seems as if your script is taking too long to execute.



All times are GMT +2. The time now is 13:28.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.