HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Problem with PureFTPd (http://www.howtoforge.com/forums/showthread.php?t=58542)

user2012 4th September 2012 17:08

Problem with PureFTPd
 
hi all, follow the steps according to Howto http://www.howtoforge.com/virtual-ho...-ubuntu-12.04.

the problem is that I can not connect to the server via FTP Filezilla for example. what I see in the file var / log / auth.log is:

Server pure-ftpd: pam_unix (pure-ftpd: auth): check pass; unknown user
Server pure-ftpd: pam_unix (pure-ftpd: auth): authentication failure; logname = uid = 0 euid = 0 tty = pure-ftpd ruser = rhost = exampleuser

and in the /var/log/message I get the following:

*Server pure-ftpd: (? @ 100.x.x.x) [INFO] New connection from 100.x.x.x
Server pure-ftpd: (? @ 100.x.x.x) [INFO] PAM_RHOST enabled. Getting the peer address
Sep 4 11:45:12 server pure-ftpd: (? @ 100.x.x.x) [WARNING] Authentication failed for user [exampleuser]
Sep 4 11:45:12 server pure-ftpd: (? @ 100.x.x.x) [INFO] Logout.

if I can help with this, thank you very much

Alex
Santiago
Chile.

falko 5th September 2012 17:32

Is this a virtual machine or a physical server?

user2012 5th September 2012 18:05

is a physical server,

thanks

falko 6th September 2012 18:54

Did you follow the tutorial as close as possible? Maybe you made a typo or some other error somewhere...

user2012 7th September 2012 13:57

I do not think, do the same installation 2 times, reinstalled operating system to rule out any errors.

falko 8th September 2012 11:26

Did you try both active and passive transfers in your FTP client?

user2012 10th September 2012 15:03

estimated, modify parameters (Active and Pasive) in FTP client does not work. when I try to connect to the FTP server via LAN, via console, I get the following message:

220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 09:40. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
Name (100.x.x.x:user): exampleuser
331 User exampleuser OK. Password required
Password:
530 Login authentication failed
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp>

thanks.

falko 11th September 2012 09:19

Looks like you're using a wrong password. Have you tried to set another one?

If that doesn't help: do your passwords contain special characters?

user2012 12th September 2012 15:45

I tried putting in MD5 password, ENCRYPT and neither works. I have no special characters, just plain text. not connected.

thanks.

falko 13th September 2012 21:16

Not sure what's wrong, but you must have done something wrong. I know that the tutorial works as described, I've used it many times. Please double-check.


All times are GMT +2. The time now is 00:57.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.