HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   SMTP authentification: Postfix and Dovecot SASL (http://www.howtoforge.com/forums/showthread.php?t=58471)

wakary 2nd September 2012 10:39

SMTP authentification: Postfix and Dovecot SASL
 
I have a Ubuntu server 12.04 hosted in another country.

I have installed Postfix and Dovecot for my mail server.
I can receive mail from services like yahoo and google.
I can view my server inbox using Sylpheed with IMAP or POP3.
I can send mail anywhere (tested with yahoo, google , hotmail).

If I: telnet localhost 25 from the server I can send mail.
But if I: telnet server_domain 25 from home I can't send mail (relay acces denied). I know this happens because my home ip is not in the mynetworks parameter in postfix, but because I have a dynamic ip I can't set it in the config file.

So I want to connect with SASL authentication to be able to send mail.

Following the Dovecot documentation on Postfix/Dovecot SASL I configured both Dovecot and Postfix for SASL but when I telnet I don't receive this message: 250-AUTH PLAIN LOGIN.

I know my dovecot configuration is not set right because I get errors like this when starting up dovecot:
"doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:10: userdb passwd {} has been replaced by userdb { driver=passwd }
"
If I put this:
auth default {

mechanisms = plain login

passdb pam {
}

userdb passwd {
}

socket listen {

client {

path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}}}
In the dovecot.conf file (the syntax is diferent in my version of dovecot (2.0.19) than all the guides I found on google)

Can you translate the configuration above in the new dovecot syntax?

wakary 2nd September 2012 13:57

Solved it
 
The configuration for dovecot is in 2 places /etc/dovecot/dovecot.conf and in /etc/dovecot/conf.d.

I found the necessary configuration parameters commented in: /etc/dovecot/conf.d/10-master.conf


All times are GMT +2. The time now is 19:49.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.