HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   php-fpm configuration on nginx (http://www.howtoforge.com/forums/showthread.php?t=58457)

ijujym 31st August 2012 15:24

php-fpm configuration on nginx
 
Hi all,
Im tuning up the Centos vps with ispconfig and nginx for Drupal 7 site. Ispconfig is realy greate panel and all works fine. But there is one problem with configurations I cant fix myself, the site has an XML import plugin and it suppose to handle large 5-10mb documents. Currently there is such error on import:

Code:

[error] 11085#0: *389 upstream timed out (110: Connection timed out) while reading response header from upstream, client ... upstream: "fastcgi://127.0.0.1:9013"
After searching for solutions for this error I have already increased the max_execution_time but cant find how to increase max_client to check if it is the reason. Please help, what can be the reason this error?

falko 1st September 2012 08:53

You might have to set something like

Code:

fastcgi_read_timeout 240;
To do this, copy your location ~ \.php$ {} section, place it inside the location / {} section and add the above line to the new location ~ \.php$ {} section.

abdi 12th December 2012 12:52

Hi Falko,

Is it possible to set that variable through API. Ie setting

Code:

fastcgi_read_timeout 240;
ALL through API

falko 14th December 2012 18:14

You can use the nginx Directives field for this.


All times are GMT +2. The time now is 22:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.