HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   Dual server with ISPConfig 3 but with errors (http://www.howtoforge.com/forums/showthread.php?t=58356)

alphaman36 23rd August 2012 10:58

Dual server with ISPConfig 3 but with errors
 
I was able to successfully install and get running ISPConfig 3 on multiple servers. 1 - email, 2 -name servers. The only thing that I am seeing that doesn't look good is the following errors in mail server.log:

Aug 23 02:11:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:11:33 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8783, input bytes=0
Aug 23 02:12:03 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8783, input bytes=0
Aug 23 02:12:03 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:12:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:12:38 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8783, input bytes=0
Aug 23 02:13:02 mail1 dovecot: pop3-login: Disconnected: Inactivity (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Aug 23 02:13:03 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:13:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:15:02 mail1 postfix/smtpd[8851]: connect from localhost.localdomain[127.0.0.1]
Aug 23 02:15:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:15:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:15:02 mail1 postfix/smtpd[8851]: fatal: no SASL authentication mechanisms
Aug 23 02:15:02 mail1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Aug 23 02:15:03 mail1 postfix/master[2293]: warning: process /usr/lib/postfix/smtpd pid 8851 exit status 1
Aug 23 02:15:03 mail1 postfix/master[2293]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Aug 23 02:15:31 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8852, input bytes=0
Aug 23 02:16:01 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8852, input bytes=0
Aug 23 02:16:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:16:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:16:36 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8852, input bytes=0
Aug 23 02:17:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:17:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:17:32 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8852, input bytes=0
Aug 23 02:18:02 mail1 dovecot: pop3-login: Disconnected: Inactivity (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured

and the following errors in mail error.log:

Aug 23 02:16:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:16:36 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8852, input bytes=0
Aug 23 02:17:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:17:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:17:32 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8852, input bytes=0
Aug 23 02:18:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:18:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:20:03 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:20:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:20:03 mail1 postfix/smtpd[8923]: fatal: no SASL authentication mechanisms
Aug 23 02:20:37 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8924, input bytes=0
Aug 23 02:21:03 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:21:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:21:33 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8924, input bytes=0
Aug 23 02:22:03 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8924, input bytes=0
Aug 23 02:22:03 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:22:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:22:38 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8924, input bytes=0
Aug 23 02:23:03 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:23:03 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:25:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:25:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:25:02 mail1 postfix/smtpd[8992]: fatal: no SASL authentication mechanisms
Aug 23 02:25:37 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8993, input bytes=0
Aug 23 02:26:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:26:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:26:32 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8993, input bytes=0
Aug 23 02:27:02 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8993, input bytes=0
Aug 23 02:27:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Aug 23 02:27:02 mail1 dovecot: master: Error: service(auth): command startup failed, throttling
Aug 23 02:27:37 mail1 dovecot: pop3-login: Error: Timeout waiting for handshake from auth server. my pid=8993, input bytes=0


Does anyone have any idea what I can do to fix this?

till 23rd August 2012 11:22

Quote:

Aug 23 02:15:02 mail1 dovecot: auth: Fatal: Unknown database driver 'mysql'
Sems a sif dovecot was compiled without mysql support. Which tutorial did you follow to install your servers?

alphaman36 23rd August 2012 11:30

Hybred
 
I used some from the perfect build for ubuntu 12.04 and with debian 5. The reason being for this is there are required steps needed in 12.04

till 23rd August 2012 12:03

So the servers are Ubuntu 12.04 and not debian? Which command did you use to install dovecot?

alphaman36 23rd August 2012 12:16

The command I ran was apt-get -y install postfix postfix-mysql postfix-doc mysql-client mysql-server openssl getmail4 rkhunter binutils dovecot-imapd dovecot-pop3d.


However since it is a virtual machine I took a snapshot a ran the command from ubuntu 12.04 perfect build which is apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server openssl getmail4 rkhunter binutils dovecot-imapd dovecot-pop3d dovecot-mysql dovecot-sieve sudo. It installed the missing products and so far it looks like that MAY have taken care of that problem. However another showed up. However I am not sure what to make of this message from the mail log:

dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Aug 23 03:55:04 mail1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Aug 23 03:55:04 mail1 postfix/smtpd[1981]: connect from localhost.localdomain[127.0.0.1]
Aug 23 03:55:04 mail1 postfix/smtpd[1981]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Aug 23 03:55:04 mail1 postfix/smtpd[1981]: disconnect from localhost.localdomain[127.0.0.1]
Aug 23 04:00:02 mail1 postfix/smtpd[2052]: connect from localhost.localdomain[127.0.0.1]
Aug 23 04:00:02 mail1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Aug 23 04:00:03 mail1 postfix/smtpd[2052]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Aug 23 04:00:03 mail1 postfix/smtpd[2052]: disconnect from localhost.localdomain[127.0.0.1]

till 23rd August 2012 12:26

The messages are from system monitoring, so they dont indicate a problem or error. The system monitor Checks every 5 minutes if the services are responding correctly.

alphaman36 23rd August 2012 12:32

Thank you
 
Thank you VERY much. I have been working on this for the last week to get everything working with multiple servers and ISPConfig 3. By the way, is there anyone that you know of that has domain.com that can point me in the correct direction so that they can see my new name servers

alphaman36 23rd August 2012 12:53

one last question
 
How do I fix this

Aug 23 04:43:45 mail1 amavis[1046]: Net::Server: Group Not Defined. Defaulting to EGID '120 120'
Aug 23 04:43:45 mail1 amavis[1046]: Net::Server: User Not Defined. Defaulting to EUID '112'

till 23rd August 2012 12:59

Seems as the user and group that amavis uses or the user and group vmail are missing. The amavis user and group are created by apt when amavis gets installed while the vmail user and group get created by ispconfig when you install it.


All times are GMT +2. The time now is 10:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.